summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-pages/man-pages_4.16.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/man-pages/man-pages_4.16.bb')
-rw-r--r--meta/recipes-extended/man-pages/man-pages_4.16.bb37
1 files changed, 37 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-pages/man-pages_4.16.bb b/meta/recipes-extended/man-pages/man-pages_4.16.bb
new file mode 100644
index 0000000000..0fa124fe7c
--- /dev/null
+++ b/meta/recipes-extended/man-pages/man-pages_4.16.bb
@@ -0,0 +1,37 @@
1SUMMARY = "Linux man-pages"
2DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs"
3SECTION = "console/utils"
4HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
5LICENSE = "GPLv2+"
6
7LIC_FILES_CHKSUM = "file://README;md5=794f701617cc03fe50c53257660d8ec4"
8SRC_URI = "${KERNELORG_MIRROR}/linux/docs/${BPN}/Archive/${BP}.tar.gz"
9
10SRC_URI[md5sum] = "d1fb8ba312a1c15e0bfda911a98c5544"
11SRC_URI[sha256sum] = "d38b0460bf3f35c95faf7f8cf52dac1216d86a47866f5e5f2fda88c61da04960"
12
13inherit manpages
14
15MAN_PKG = "${PN}"
16
17# help manpages.bbclass deal with RDEPNDS and postinstall scripts
18PACKAGECONFIG = "manpages"
19PACKAGECONFIG[manpages] = ""
20
21do_configure[noexec] = "1"
22do_compile[noexec] = "1"
23
24do_install() {
25 oe_runmake install DESTDIR=${D}
26}
27
28# Only deliveres man-pages so FILES_${PN} gets everything
29FILES_${PN}-doc = ""
30FILES_${PN} = "${mandir}/*"
31
32inherit update-alternatives
33
34ALTERNATIVE_PRIORITY = "100"
35ALTERNATIVE_${PN} = "passwd.5 getspnam.3"
36ALTERNATIVE_LINK_NAME[passwd.5] = "${mandir}/man5/passwd.5"
37ALTERNATIVE_LINK_NAME[getspnam.3] = "${mandir}/man3/getspnam.3"