summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-pages/man-pages_4.08.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/man-pages/man-pages_4.08.bb')
-rw-r--r--meta/recipes-extended/man-pages/man-pages_4.08.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-pages/man-pages_4.08.bb b/meta/recipes-extended/man-pages/man-pages_4.08.bb
new file mode 100644
index 0000000000..8fc6cb0a5d
--- /dev/null
+++ b/meta/recipes-extended/man-pages/man-pages_4.08.bb
@@ -0,0 +1,31 @@
1SUMMARY = "Linux man-pages"
2DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs"
3SECTION = "console/utils"
4HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
5LICENSE = "GPLv2+"
6
7LIC_FILES_CHKSUM = "file://README;md5=8f2a3d43057d458e5066714980567a60"
8SRC_URI = "${KERNELORG_MIRROR}/linux/docs/${BPN}/Archive/${BP}.tar.gz"
9
10SRC_URI[md5sum] = "88760ffa6cf92495327758b828850015"
11SRC_URI[sha256sum] = "1fa6529ab2784e7db2a498feb2c5307f4afb87dff0e3321e5964265e2e8433fd"
12
13RDEPENDS_${PN} = "man"
14
15do_configure[noexec] = "1"
16do_compile[noexec] = "1"
17
18do_install() {
19 oe_runmake install DESTDIR=${D}
20}
21
22# Only deliveres man-pages so FILES_${PN} gets everything
23FILES_${PN}-doc = ""
24FILES_${PN} = "${mandir}/*"
25
26inherit update-alternatives
27
28ALTERNATIVE_PRIORITY = "100"
29ALTERNATIVE_${PN} = "passwd.5 getspnam.3"
30ALTERNATIVE_LINK_NAME[passwd.5] = "${mandir}/man5/passwd.5"
31ALTERNATIVE_LINK_NAME[getspnam.3] = "${mandir}/man3/getspnam.3"