summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-pages/man-pages_3.75.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/man-pages/man-pages_3.75.bb')
-rw-r--r--meta/recipes-extended/man-pages/man-pages_3.75.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-pages/man-pages_3.75.bb b/meta/recipes-extended/man-pages/man-pages_3.75.bb
new file mode 100644
index 0000000000..18e2bca8e4
--- /dev/null
+++ b/meta/recipes-extended/man-pages/man-pages_3.75.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Linux man-pages"
2DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs"
3SECTION = "console/utils"
4HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
5LICENSE = "GPLv2+"
6
7LIC_FILES_CHKSUM = "file://README;md5=8f2a3d43057d458e5066714980567a60"
8SRC_URI = "${KERNELORG_MIRROR}/linux/docs/${BPN}/Archive/${BP}.tar.gz"
9
10SRC_URI[md5sum] = "74ad4aef657a046fe214bf981a9a2b30"
11SRC_URI[sha256sum] = "ba23f57a98d032a742ff506f32550dfa2c3076c8bf8d5f6b59305c6b015077d3"
12
13RDEPENDS_${PN} = "man"
14
15do_configure () {
16 :
17}
18
19do_compile() {
20 :
21}
22
23do_install() {
24 oe_runmake install DESTDIR=${D}
25}
26
27# Only deliveres man-pages so FILES_${PN} gets everything
28FILES_${PN}-doc = ""
29FILES_${PN} = "${mandir}/*"
30
31inherit update-alternatives
32
33ALTERNATIVE_PRIORITY = "100"
34ALTERNATIVE_${PN} = "passwd.5 getspnam.3"
35ALTERNATIVE_LINK_NAME[passwd.5] = "${mandir}/man5/passwd.5"
36ALTERNATIVE_LINK_NAME[getspnam.3] = "${mandir}/man3/getspnam.3"