summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-pages/man-pages_3.36.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/man-pages/man-pages_3.36.bb')
-rw-r--r--meta/recipes-extended/man-pages/man-pages_3.36.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-pages/man-pages_3.36.bb b/meta/recipes-extended/man-pages/man-pages_3.36.bb
new file mode 100644
index 0000000000..4e888dc07e
--- /dev/null
+++ b/meta/recipes-extended/man-pages/man-pages_3.36.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Linux man-pages"
2DESCRIPTION = "The Linux man-pages project documents the Linux kernel and C library interfaces that are employed by user programs"
3SECTION = "console/utils"
4HOMEPAGE = "http://www.kernel.org/pub/linux/docs/man-pages"
5LICENSE = "GPLv2+"
6PR = "r0"
7
8LIC_FILES_CHKSUM = "file://README;md5=0422377a748010b2b738342e24f141c1"
9SRC_URI = "${KERNELORG_MIRROR}/linux/docs/man-pages/Archive/${BPN}-${PV}.tar.gz"
10
11SRC_URI[md5sum] = "cfe991b1ce9e0ea5355f29ff9fcac125"
12SRC_URI[sha256sum] = "c0575e31f73cd9dc2761c274217e06e7130fdfee510170957a9d72d012a5437c"
13
14RDEPENDS_${PN} = "man"
15
16do_configure_prepend() {
17 rm -rf not_installed
18}
19
20do_configure () {
21 :
22}
23
24do_compile() {
25 oe_runmake -f Makefile DESTDIR=${D} MANDIR=${D}${mandir}
26}
27
28fakeroot do_install() {
29 oe_runmake install DESTDIR=${D}
30}
31
32FILES_${PN} += "${datadir}/man/"