summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/man-db/man-db_2.8.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/man-db/man-db_2.8.3.bb')
-rw-r--r--meta/recipes-extended/man-db/man-db_2.8.3.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-db/man-db_2.8.3.bb b/meta/recipes-extended/man-db/man-db_2.8.3.bb
new file mode 100644
index 0000000000..412e5727cd
--- /dev/null
+++ b/meta/recipes-extended/man-db/man-db_2.8.3.bb
@@ -0,0 +1,43 @@
1SUMMARY = "An implementation of the standard Unix documentation system accessed using the man command"
2HOMEPAGE = "http://man-db.nongnu.org/"
3LICENSE = "LGPLv2.1 & GPLv2"
4LIC_FILES_CHKSUM = "file://docs/COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \
5 file://docs/COPYING;md5=eb723b61539feef013de476e68b5c50a"
6
7SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/man-db/man-db-${PV}.tar.xz"
8SRC_URI[md5sum] = "6f3055e18fdd1ce5cbbdb30403991ec7"
9SRC_URI[sha256sum] = "5932a1ca366e1ec61a3ece1a3afa0e92f2fdc125b61d236f20cc6ff9d80cc4ac"
10
11DEPENDS = "libpipeline gdbm groff-native"
12
13# | /usr/src/debug/man-db/2.8.0-r0/man-db-2.8.0/src/whatis.c:939: undefined reference to `_nl_msg_cat_cntr'
14USE_NLS_libc-musl = "no"
15
16inherit gettext pkgconfig autotools
17
18EXTRA_OECONF = "--with-pager=less --disable-cache-owner"
19
20do_install_append_libc-musl() {
21 rm -f ${D}${libdir}/charset.alias
22}
23
24FILES_${PN} += "${prefix}/lib/tmpfiles.d"
25
26FILES_${PN}-dev += "${libdir}/man-db/libman.so ${libdir}/${BPN}/libmandb.so"
27
28RDEPENDS_${PN} += "groff"
29RRECOMMENDS_${PN} += "less"
30RPROVIDES_${PN} += " man"
31
32def compress_pkg(d):
33 if bb.utils.contains("INHERIT", "compress_doc", True, False, d):
34 compress = d.getVar("DOC_COMPRESS")
35 if compress == "gz":
36 return "gzip"
37 elif compress == "bz2":
38 return "bzip2"
39 elif compress == "xz":
40 return "xz"
41 return ""
42
43RDEPENDS_${PN} += "${@compress_pkg(d)}"