diff options
Diffstat (limited to 'meta/recipes-extended/man-db/man-db_2.8.1.bb')
-rw-r--r-- | meta/recipes-extended/man-db/man-db_2.8.1.bb | 42 |
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-extended/man-db/man-db_2.8.1.bb b/meta/recipes-extended/man-db/man-db_2.8.1.bb new file mode 100644 index 0000000000..528903d6fa --- /dev/null +++ b/meta/recipes-extended/man-db/man-db_2.8.1.bb | |||
@@ -0,0 +1,42 @@ | |||
1 | SUMMARY = "An implementation of the standard Unix documentation system accessed using the man command" | ||
2 | HOMEPAGE = "http://man-db.nongnu.org/" | ||
3 | LICENSE = "LGPLv2.1 & GPLv2" | ||
4 | LIC_FILES_CHKSUM = "file://docs/COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \ | ||
5 | file://docs/COPYING;md5=eb723b61539feef013de476e68b5c50a" | ||
6 | |||
7 | SRC_URI = "${SAVANNAH_NONGNU_MIRROR}/man-db/man-db-${PV}.tar.xz" | ||
8 | SRC_URI[md5sum] = "51842978e06686286421f9498d1009b7" | ||
9 | SRC_URI[sha256sum] = "a6aec641ca3d9942b054cc0e9c3f05cb46a3a992bc0006795755e2fed1357f3e" | ||
10 | |||
11 | DEPENDS = "libpipeline gdbm groff-native" | ||
12 | |||
13 | # | /usr/src/debug/man-db/2.8.0-r0/man-db-2.8.0/src/whatis.c:939: undefined reference to `_nl_msg_cat_cntr' | ||
14 | USE_NLS_libc-musl = "no" | ||
15 | |||
16 | inherit gettext pkgconfig autotools | ||
17 | |||
18 | EXTRA_OECONF = "--with-pager=less --disable-cache-owner" | ||
19 | |||
20 | do_install_append_libc-musl() { | ||
21 | rm -f ${D}${libdir}/charset.alias | ||
22 | } | ||
23 | |||
24 | FILES_${PN} += "${prefix}/lib/tmpfiles.d" | ||
25 | |||
26 | FILES_${PN}-dev += "${libdir}/man-db/libman.so ${libdir}/${BPN}/libmandb.so" | ||
27 | |||
28 | RRECOMMENDS_${PN} += "less" | ||
29 | RPROVIDES_${PN} += " man" | ||
30 | |||
31 | def compress_pkg(d): | ||
32 | if bb.utils.contains("INHERIT", "compress_doc", True, False, d): | ||
33 | compress = d.getVar("DOC_COMPRESS") | ||
34 | if compress == "gz": | ||
35 | return "gzip" | ||
36 | elif compress == "bz2": | ||
37 | return "bzip2" | ||
38 | elif compress == "xz": | ||
39 | return "xz" | ||
40 | return "" | ||
41 | |||
42 | RDEPENDS_${PN} += "${@compress_pkg(d)}" | ||