summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp/ltp_20210121.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/ltp/ltp_20210121.bb')
-rw-r--r--meta/recipes-extended/ltp/ltp_20210121.bb133
1 files changed, 0 insertions, 133 deletions
diff --git a/meta/recipes-extended/ltp/ltp_20210121.bb b/meta/recipes-extended/ltp/ltp_20210121.bb
deleted file mode 100644
index 593f07087c..0000000000
--- a/meta/recipes-extended/ltp/ltp_20210121.bb
+++ /dev/null
@@ -1,133 +0,0 @@
1SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "https://linux-test-project.github.io/"
4SECTION = "console/utils"
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
9 file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \
10 file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
11 file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
12 file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \
13 file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
14 file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
15"
16
17DEPENDS = "attr libaio libcap acl openssl zip-native"
18DEPENDS_append_libc-musl = " fts "
19EXTRA_OEMAKE_append_libc-musl = " LIBC=musl "
20EXTRA_OECONF_append_libc-musl = " LIBS=-lfts "
21
22# since ltp contains x86-64 assembler which uses the frame-pointer register,
23# set -fomit-frame-pointer x86-64 to handle cases where optimisation
24# is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer
25# earlier in CFLAGS, etc.
26CFLAGS_append_x86-64 = " -fomit-frame-pointer"
27
28CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__"
29CFLAGS_append_mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
30SRCREV = "4d005621edd109d119627eb9210b224a63bf22cb"
31
32# remove at next version upgrade or when output changes
33PR = "r1"
34HASHEQUIV_HASH_VERSION .= ".1"
35
36SRC_URI = "git://github.com/linux-test-project/ltp.git \
37 file://0001-build-Add-option-to-select-libc-implementation.patch \
38 file://0007-Fix-test_proc_kill-hanging.patch \
39 file://0001-Add-more-musl-exclusions.patch \
40 file://0001-Remove-OOM-tests-from-runtest-mm.patch \
41 file://determinism.patch \
42 "
43
44S = "${WORKDIR}/git"
45
46inherit autotools-brokensep pkgconfig
47
48TARGET_CC_ARCH += "${LDFLAGS}"
49
50export prefix = "/opt/${PN}"
51export exec_prefix = "/opt/${PN}"
52
53PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
54EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
55EXTRA_OECONF = " --with-realtime-testsuite --with-open-posix-testsuite "
56# ltp network/rpc test cases ftbfs when libtirpc is found
57EXTRA_OECONF += " --without-tirpc "
58
59do_compile_prepend() {
60 # Reported at http://lists.linux.it/pipermail/ltp/2021-March/021274.html
61 # Avoid a race over construction of libswapon.o which is built by swapon and swapoff
62 # but the object differs depending upon which one built it
63 # ("../swapon/libswapon.c" vs "libswapon.c" references)
64 make -C ${B}/testcases/kernel/syscalls/swapon/
65}
66
67do_install(){
68 install -d ${D}${prefix}/
69 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install
70
71 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
72 # as it lacks dependency on some perl moudle such as LWP::Simple
73 # And this script previously works as a tool for analyzing failures from LTP
74 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
75 # http://khack.osdl.org to retrieve ltp test results run on
76 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
77 rm -rf ${D}${prefix}/bin/STPfailure_report.pl
78
79 # Copy POSIX test suite into ${D}${prefix}/testcases by manual
80 cp -r testcases/open_posix_testsuite ${D}${prefix}/testcases
81
82 # Makefile were configured in the build system
83 find ${D}${prefix} -name Makefile | xargs -n 1 sed -i \
84 -e 's@[^ ]*-fdebug-prefix-map=[^ "]*@@g' \
85 -e 's@[^ ]*-fmacro-prefix-map=[^ "]*@@g' \
86 -e 's@[^ ]*--sysroot=[^ "]*@@g'
87
88 # The controllers memcg_stree test seems to cause us hangs and takes 900s
89 # (maybe we expect more regular output?), anyhow, skip it
90 sed -e '/^memcg_stress/d' -i ${D}${prefix}/runtest/controllers
91}
92
93RDEPENDS_${PN} = "\
94 attr \
95 bash \
96 bc \
97 coreutils \
98 cpio \
99 cronie \
100 curl \
101 e2fsprogs \
102 e2fsprogs-mke2fs \
103 expect \
104 file \
105 gawk \
106 gdb \
107 gzip \
108 iproute2 \
109 ldd \
110 libaio \
111 logrotate \
112 net-tools \
113 perl \
114 python3-core \
115 procps \
116 quota \
117 unzip \
118 util-linux \
119 which \
120 tar \
121"
122
123FILES_${PN} += "${prefix}/* ${prefix}/runtest/* ${prefix}/scenario_groups/* ${prefix}/testcases/bin/* ${prefix}/testcases/bin/*/bin/* ${prefix}/testscripts/* ${prefix}/testcases/open_posix_testsuite/* ${prefix}/testcases/open_posix_testsuite/conformance/* ${prefix}/testcases/open_posix_testsuite/Documentation/* ${prefix}/testcases/open_posix_testsuite/functional/* ${prefix}/testcases/open_posix_testsuite/include/* ${prefix}/testcases/open_posix_testsuite/scripts/* ${prefix}/testcases/open_posix_testsuite/stress/* ${prefix}/testcases/open_posix_testsuite/tools/* ${prefix}/testcases/data/nm01/lib.a ${prefix}/lib/libmem.a"
124
125# Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail
126INHIBIT_PACKAGE_STRIP_FILES = "${prefix}/testcases/bin/nm01 ${prefix}/testcases/bin/ldd01"
127INSANE_SKIP_${PN} += "already-stripped staticdev"
128
129# Avoid file dependency scans, as LTP checks for things that may or may not
130# exist on the running system. For instance it has specific checks for
131# csh and ksh which are not typically part of OpenEmbedded systems (but
132# can be added via additional layers.)
133SKIP_FILEDEPS_${PN} = '1'