diff options
Diffstat (limited to 'meta/recipes-extended/ltp/ltp_20200120.bb')
-rw-r--r-- | meta/recipes-extended/ltp/ltp_20200120.bb | 109 |
1 files changed, 109 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp_20200120.bb b/meta/recipes-extended/ltp/ltp_20200120.bb new file mode 100644 index 0000000000..3cc10afa0c --- /dev/null +++ b/meta/recipes-extended/ltp/ltp_20200120.bb | |||
@@ -0,0 +1,109 @@ | |||
1 | SUMMARY = "Linux Test Project" | ||
2 | DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features." | ||
3 | HOMEPAGE = "https://linux-test-project.github.io/" | ||
4 | SECTION = "console/utils" | ||
5 | LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause" | ||
6 | LIC_FILES_CHKSUM = "\ | ||
7 | file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \ | ||
8 | file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \ | ||
9 | file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \ | ||
10 | file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \ | ||
11 | file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \ | ||
12 | file://testcases/open_posix_testsuite/COPYING;md5=48b1c5ec633e3e30ec2cf884ae699947 \ | ||
13 | file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \ | ||
14 | file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
15 | " | ||
16 | |||
17 | DEPENDS = "attr libaio libcap acl openssl zip-native" | ||
18 | DEPENDS_append_libc-musl = " fts " | ||
19 | EXTRA_OEMAKE_append_libc-musl = " LIBC=musl " | ||
20 | EXTRA_OECONF_append_libc-musl = " LIBS=-lfts " | ||
21 | |||
22 | # since ltp contains x86-64 assembler which uses the frame-pointer register, | ||
23 | # set -fomit-frame-pointer x86-64 to handle cases where optimisation | ||
24 | # is set to -O0 or frame pointers have been enabled by -fno-omit-frame-pointer | ||
25 | # earlier in CFLAGS, etc. | ||
26 | CFLAGS_append_x86-64 = " -fomit-frame-pointer" | ||
27 | |||
28 | CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__" | ||
29 | CFLAGS_append_mipsarchn64 = " -D__SANE_USERSPACE_TYPES__" | ||
30 | SRCREV = "4079aaf264d0e9ead042b59d1c5f4e643620d0d5" | ||
31 | |||
32 | SRC_URI = "git://github.com/linux-test-project/ltp.git \ | ||
33 | file://0001-build-Add-option-to-select-libc-implementation.patch \ | ||
34 | file://0003-Check-if-__GLIBC_PREREQ-is-defined-before-using-it.patch \ | ||
35 | file://0004-guard-mallocopt-with-__GLIBC__.patch \ | ||
36 | file://0007-Fix-test_proc_kill-hanging.patch \ | ||
37 | file://0008-testcases-network-nfsv4-acl-acl1.c-Security-fix-on-s.patch \ | ||
38 | file://0009-open_posix_testsuite-mmap24-2-Relax-condition-a-bit.patch \ | ||
39 | file://0001-Add-more-musl-exclusions.patch \ | ||
40 | file://0001-syscalls-Check-for-time64-unsafe-syscalls-before-usi.patch \ | ||
41 | " | ||
42 | |||
43 | S = "${WORKDIR}/git" | ||
44 | |||
45 | inherit autotools-brokensep | ||
46 | |||
47 | TARGET_CC_ARCH += "${LDFLAGS}" | ||
48 | |||
49 | export prefix = "/opt/ltp" | ||
50 | export exec_prefix = "/opt/ltp" | ||
51 | |||
52 | PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl," | ||
53 | EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4" | ||
54 | EXTRA_OECONF = " --with-power-management-testsuite --with-realtime-testsuite --with-open-posix-testsuite " | ||
55 | # ltp network/rpc test cases ftbfs when libtirpc is found | ||
56 | EXTRA_OECONF += " --without-tirpc " | ||
57 | |||
58 | do_install(){ | ||
59 | install -d ${D}/opt/ltp/ | ||
60 | oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install | ||
61 | |||
62 | # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run | ||
63 | # as it lacks dependency on some perl moudle such as LWP::Simple | ||
64 | # And this script previously works as a tool for analyzing failures from LTP | ||
65 | # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses | ||
66 | # http://khack.osdl.org to retrieve ltp test results run on | ||
67 | # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible | ||
68 | rm -rf ${D}/opt/ltp/bin/STPfailure_report.pl | ||
69 | |||
70 | # Copy POSIX test suite into ${D}/opt/ltp/testcases by manual | ||
71 | cp -r testcases/open_posix_testsuite ${D}/opt/ltp/testcases | ||
72 | } | ||
73 | |||
74 | RDEPENDS_${PN} = "\ | ||
75 | attr \ | ||
76 | bash \ | ||
77 | cpio \ | ||
78 | cronie \ | ||
79 | curl \ | ||
80 | e2fsprogs-mke2fs \ | ||
81 | expect \ | ||
82 | file \ | ||
83 | gawk \ | ||
84 | gzip \ | ||
85 | iproute2 \ | ||
86 | ldd \ | ||
87 | libaio \ | ||
88 | logrotate \ | ||
89 | perl \ | ||
90 | python3-core \ | ||
91 | procps \ | ||
92 | quota \ | ||
93 | unzip \ | ||
94 | util-linux \ | ||
95 | which \ | ||
96 | tar \ | ||
97 | " | ||
98 | |||
99 | FILES_${PN} += "/opt/ltp/* /opt/ltp/runtest/* /opt/ltp/scenario_groups/* /opt/ltp/testcases/bin/* /opt/ltp/testcases/bin/*/bin/* /opt/ltp/testscripts/* /opt/ltp/testcases/open_posix_testsuite/* /opt/ltp/testcases/open_posix_testsuite/conformance/* /opt/ltp/testcases/open_posix_testsuite/Documentation/* /opt/ltp/testcases/open_posix_testsuite/functional/* /opt/ltp/testcases/open_posix_testsuite/include/* /opt/ltp/testcases/open_posix_testsuite/scripts/* /opt/ltp/testcases/open_posix_testsuite/stress/* /opt/ltp/testcases/open_posix_testsuite/tools/* /opt/ltp/testcases/data/nm01/lib.a /opt/ltp/lib/libmem.a" | ||
100 | |||
101 | # Avoid stripping some generated binaries otherwise some of the ltp tests such as ldd01 & nm01 fail | ||
102 | INHIBIT_PACKAGE_STRIP_FILES = "/opt/ltp/testcases/bin/nm01 /opt/ltp/testcases/bin/ldd01" | ||
103 | INSANE_SKIP_${PN} += "already-stripped staticdev" | ||
104 | |||
105 | # Avoid file dependency scans, as LTP checks for things that may or may not | ||
106 | # exist on the running system. For instance it has specific checks for | ||
107 | # csh and ksh which are not typically part of OpenEmbedded systems (but | ||
108 | # can be added via additional layers.) | ||
109 | SKIP_FILEDEPS_${PN} = '1' | ||