summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp/ltp_20170116.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/ltp/ltp_20170116.bb')
-rw-r--r--meta/recipes-extended/ltp/ltp_20170116.bb109
1 files changed, 109 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp_20170116.bb b/meta/recipes-extended/ltp/ltp_20170116.bb
new file mode 100644
index 0000000000..a5494bc809
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp_20170116.bb
@@ -0,0 +1,109 @@
1SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "http://ltp.sourceforge.net"
4SECTION = "console/utils"
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
8 file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
9 file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \
10 file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
11 file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
12 file://testcases/open_posix_testsuite/COPYING;md5=216e43b72efbe4ed9017cc19c4c68b01 \
13 file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
14 file://tools/pounder21/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
15 file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
16 file://utils/ffsb-6.0-rc2/COPYING;md5=c46082167a314d785d012a244748d803 \
17"
18
19DEPENDS = "attr libaio libcap acl openssl zip-native"
20DEPENDS_append_libc-musl = " fts "
21EXTRA_OEMAKE_append_libc-musl = " LIBC=musl "
22CFLAGS_append_powerpc64 = " -D__SANE_USERSPACE_TYPES__"
23CFLAGS_append_mipsarchn64 = " -D__SANE_USERSPACE_TYPES__"
24SRCREV = "2c8457b0769fc026e4e1772f4c2a6da0be63a631"
25
26SRC_URI = "git://github.com/linux-test-project/ltp.git \
27 file://0001-add-_GNU_SOURCE-to-pec_listener.c.patch \
28 file://0002-Add-knob-to-control-whether-numa-support-should-be-c.patch \
29 file://0003-Add-knob-to-control-tirpc-support.patch \
30 file://0004-build-Add-option-to-select-libc-implementation.patch \
31 file://0005-kernel-controllers-Link-with-libfts-explicitly-on-mu.patch \
32 file://0006-fix-PATH_MAX-undeclared-when-building-with-musl.patch \
33 file://0007-fix-__WORDSIZE-undeclared-when-building-with-musl.patch \
34 file://0008-Check-if-__GLIBC_PREREQ-is-defined-before-using-it.patch \
35 file://0009-fix-redefinition-of-struct-msgbuf-error-building-wit.patch \
36 file://0010-replace-__BEGIN_DECLS-and-__END_DECLS.patch \
37 file://0011-Rename-sigset-variable-to-sigset1.patch \
38 file://0012-fix-faccessat01.c-build-fails-with-security-flags.patch \
39 file://0018-guard-mallocopt-with-__GLIBC__.patch \
40 file://0020-getdents-define-getdents-getdents64-only-for-glibc.patch \
41 file://0021-Define-_GNU_SOURCE-for-MREMAP_MAYMOVE-definition.patch \
42 file://0023-ptrace-Use-int-instead-of-enum-__ptrace_request.patch \
43 file://0024-rt_sigaction-rt_sigprocmark-Define-_GNU_SOURCE.patch \
44 file://0025-mc_gethost-include-sys-types.h.patch \
45 file://0026-crash01-Define-_GNU_SOURCE.patch \
46 file://0027-sysconf01-Use-_SC_2_C_VERSION-conditionally.patch \
47 file://0028-rt_sigaction.h-Use-sighandler_t-instead-of-__sighand.patch \
48 file://0030-lib-Use-PTHREAD_MUTEX_RECURSIVE-in-place-of-PTHREAD_.patch \
49 file://0033-shmat1-Cover-GNU-specific-code-under-__USE_GNU.patch \
50 file://0034-periodic_output.patch \
51 file://0035-fix-test_proc_kill-hang.patch \
52 file://0036-testcases-network-nfsv4-acl-acl1.c-Security-fix-on-s.patch \
53 file://0039-fcntl-fix-the-time-def-to-use-time_t.patch \
54 "
55
56S = "${WORKDIR}/git"
57
58inherit autotools-brokensep
59
60TARGET_CC_ARCH += "${LDFLAGS}"
61
62export prefix = "/opt/ltp"
63export exec_prefix = "/opt/ltp"
64
65PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
66EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
67EXTRA_OECONF = " --with-power-management-testsuite --with-realtime-testsuite "
68# ltp network/rpc test cases ftbfs when libtirpc is found
69EXTRA_OECONF += " --without-tirpc "
70
71# The makefiles make excessive use of make -C and several include testcases.mk
72# which triggers a build of the syscall header. To reproduce, build ltp,
73# then delete the header, then "make -j XX" and watch regen.sh run multiple
74# times. Its easier to generate this once here instead.
75do_compile_prepend () {
76 ( make -C ${B}/testcases/kernel include/linux_syscall_numbers.h )
77}
78
79do_install(){
80 install -d ${D}/opt/ltp/
81 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install
82
83 # fixup not deploy STPfailure_report.pl to avoid confusing about it fails to run
84 # as it lacks dependency on some perl moudle such as LWP::Simple
85 # And this script previously works as a tool for analyzing failures from LTP
86 # runs on the OSDL's Scaleable Test Platform (STP) and it mainly accesses
87 # http://khack.osdl.org to retrieve ltp test results run on
88 # OSDL's Scaleable Test Platform, but now http://khack.osdl.org unaccessible
89 rm -rf ${D}/opt/ltp/bin/STPfailure_report.pl
90
91 # In oe-core, we doesn't support ksh and csh now, so remove in.csh and in.ksh.
92 rm ${D}/opt/ltp/testcases/data/file01/in.csh
93 rm ${D}/opt/ltp/testcases/data/file01/in.ksh
94 # Copy POSIX test suite into ${D}/opt/ltp/testcases by manual
95 cp -r testcases/open_posix_testsuite ${D}/opt/ltp/testcases
96}
97
98RDEPENDS_${PN} = "perl e2fsprogs-mke2fs python-core libaio bash gawk expect ldd unzip gzip cpio cronie logrotate which at"
99
100FILES_${PN}-staticdev += "/opt/ltp/lib/libmem.a /opt/ltp/testcases/data/nm01/lib.a"
101
102FILES_${PN} += "/opt/ltp/* /opt/ltp/runtest/* /opt/ltp/scenario_groups/* /opt/ltp/testcases/bin/* /opt/ltp/testcases/bin/*/bin/* /opt/ltp/testscripts/* /opt/ltp/testcases/open_posix_testsuite/* /opt/ltp/testcases/open_posix_testsuite/conformance/* /opt/ltp/testcases/open_posix_testsuite/Documentation/* /opt/ltp/testcases/open_posix_testsuite/functional/* /opt/ltp/testcases/open_posix_testsuite/include/* /opt/ltp/testcases/open_posix_testsuite/scripts/* /opt/ltp/testcases/open_posix_testsuite/stress/* /opt/ltp/testcases/open_posix_testsuite/tools/*"
103
104# Avoid generated binaries stripping. Otherwise some of the ltp tests such as ldd01 & nm01 fails
105INHIBIT_PACKAGE_STRIP = "1"
106INHIBIT_PACKAGE_DEBUG_SPLIT = "1"
107# However, test_arch_stripped is already stripped, so...
108INSANE_SKIP_${PN} += "already-stripped"
109