summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp/ltp_20140422.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/ltp/ltp_20140422.bb')
-rw-r--r--meta/recipes-extended/ltp/ltp_20140422.bb93
1 files changed, 93 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp_20140422.bb b/meta/recipes-extended/ltp/ltp_20140422.bb
new file mode 100644
index 0000000000..0632f11ad8
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp_20140422.bb
@@ -0,0 +1,93 @@
1SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "http://ltp.sourceforge.net"
4SECTION = "console/utils"
5LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
6LIC_FILES_CHKSUM = "\
7 file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
8 file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
9 file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \
10 file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
11 file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
12 file://testcases/open_posix_testsuite/COPYING;md5=216e43b72efbe4ed9017cc19c4c68b01 \
13 file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
14 file://tools/netpipe-2.4/COPYING;md5=9e3781bb5fe787aa80e1f51f5006b6fa \
15 file://tools/netpipe-2.4-ipv6/COPYING;md5=9e3781bb5fe787aa80e1f51f5006b6fa \
16 file://tools/top-LTP/proc/COPYING;md5=aefc88eb8a41672fbfcfe6b69ab8c49c \
17 file://tools/pounder21/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
18 file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
19 file://utils/ffsb-6.0-rc2/COPYING;md5=c46082167a314d785d012a244748d803 \
20"
21
22DEPENDS = "attr libaio libcap acl openssl zip-native"
23SRCREV = "f4c3bfe1eab51eb72caeb0f3336d2790c9a8bd1b"
24
25SRC_URI = "git://github.com/linux-test-project/ltp.git \
26 file://0001-Rename-runtests_noltp.sh-script-so-have-unique-name.patch \
27 file://periodic_output.patch \
28 file://ltp-Do-not-link-against-libfl.patch \
29 file://automake-foreign.patch \
30 file://make-setregid02-work.patch \
31 file://add-knob-for-numa.patch \
32 file://0001-Realtime-tests-Fix-bad-priority-inheritance-conditio.patch \
33 file://0001-Realtime-tests-Fix-robust-mutex-conditionals.patch \
34 file://fix-test_proc_kill-hang.patch \
35"
36
37S = "${WORKDIR}/git"
38
39inherit autotools-brokensep
40
41TARGET_CC_ARCH += "${LDFLAGS}"
42
43export prefix = "/opt/ltp"
44export exec_prefix = "/opt/ltp"
45
46PACKAGECONFIG[numa] = "--with-numa, --without-numa, numactl,"
47EXTRA_AUTORECONF += "-I ${S}/testcases/realtime/m4"
48EXTRA_OECONF = " --with-power-management-testsuite --with-realtime-testsuite "
49
50# ltp doesn't regenerate ffsb-6.0-rc2 configure and hardcode configure call.
51# we explicitly force regeneration of that directory and pass configure options.
52do_configure_append() {
53 (cd utils/ffsb-6.0-rc2; autoreconf -fvi; ./configure ${CONFIGUREOPTS})
54}
55
56# The makefiles make excessive use of make -C and several include testcases.mk
57# which triggers a build of the syscall header. To reproduce, build ltp,
58# then delete the header, then "make -j XX" and watch regen.sh run multiple
59# times. Its easier to generate this once here instead.
60do_compile_prepend () {
61 ( make -C ${B}/testcases/kernel include/linux_syscall_numbers.h )
62}
63
64do_install(){
65 install -d ${D}/opt/ltp/
66 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install
67
68 # Copy POSIX test suite into ${D}/opt/ltp/testcases by manual
69 cp -r testcases/open_posix_testsuite ${D}/opt/ltp/testcases
70
71 # We need to remove all scripts which depend on /usr/bin/expect, since expect is not supported in oe-core
72 # We will add expect for enhancement in future
73 find ${D} -type f -print | xargs grep "\!.*\/usr\/bin\/expect" | awk -F":" '{print $1}' | xargs rm -f
74}
75
76RDEPENDS_${PN} = "perl e2fsprogs-mke2fs python-core libaio bash gawk"
77
78FILES_${PN}-dbg += "\
79 /opt/ltp/runtest/.debug \
80 /opt/ltp/testcases/bin/.debug \
81 /opt/ltp/testcases/bin/*/bin/.debug \
82 /opt/ltp/testcases/bin/*/test/.debug \
83 /opt/ltp/scenario_groups/.debug \
84 /opt/ltp/testscripts/.debug \
85 /opt/ltp/testscripts/open_posix_testsuite/.debug \
86"
87
88FILES_${PN}-staticdev += "/opt/ltp/lib/libmem.a"
89
90FILES_${PN} += "/opt/ltp/* /opt/ltp/runtest/* /opt/ltp/scenario_groups/* /opt/ltp/testcases/bin/* /opt/ltp/testcases/bin/*/bin/* /opt/ltp/testscripts/* /opt/ltp/testcases/open_posix_testsuite/* /opt/ltp/testcases/open_posix_testsuite/conformance/* /opt/ltp/testcases/open_posix_testsuite/Documentation/* /opt/ltp/testcases/open_posix_testsuite/functional/* /opt/ltp/testcases/open_posix_testsuite/include/* /opt/ltp/testcases/open_posix_testsuite/scripts/* /opt/ltp/testcases/open_posix_testsuite/stress/* /opt/ltp/testcases/open_posix_testsuite/tools/*"
91
92# Avoid generated binaries stripping. Otherwise some of the ltp tests such as ldd01 & nm01 fails
93INHIBIT_PACKAGE_STRIP = "1"