summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/ltp/ltp_20130904.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/ltp/ltp_20130904.bb')
-rw-r--r--meta/recipes-extended/ltp/ltp_20130904.bb75
1 files changed, 75 insertions, 0 deletions
diff --git a/meta/recipes-extended/ltp/ltp_20130904.bb b/meta/recipes-extended/ltp/ltp_20130904.bb
new file mode 100644
index 0000000000..5e104489b1
--- /dev/null
+++ b/meta/recipes-extended/ltp/ltp_20130904.bb
@@ -0,0 +1,75 @@
1SUMMARY = "Linux Test Project"
2DESCRIPTION = "The Linux Test Project is a joint project with SGI, IBM, OSDL, and Bull with a goal to deliver test suites to the open source community that validate the reliability, robustness, and stability of Linux. The Linux Test Project is a collection of tools for testing the Linux kernel and related features."
3HOMEPAGE = "http://ltp.sourceforge.net"
4SECTION = "console/utils"
5
6LICENSE = "GPLv2 & GPLv2+ & LGPLv2+ & LGPLv2.1+ & BSD-2-Clause"
7LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
8 file://testcases/kernel/controllers/freezer/COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3 \
9 file://testcases/kernel/controllers/freezer/run_freezer.sh;beginline=5;endline=17;md5=86a61d2c042d59836ffb353a21456498 \
10 file://testcases/kernel/fs/ext4-new-features/ffsb-6.0-rc2/COPYING;md5=c46082167a314d785d012a244748d803 \
11 file://testcases/kernel/hotplug/memory_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
12 file://testcases/kernel/hotplug/cpu_hotplug/COPYING;md5=e04a2e542b2b8629bf9cd2ba29b0fe41 \
13 file://testcases/open_posix_testsuite/COPYING;md5=216e43b72efbe4ed9017cc19c4c68b01 \
14 file://testcases/realtime/COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e \
15 file://tools/netpipe-2.4/COPYING;md5=9e3781bb5fe787aa80e1f51f5006b6fa \
16 file://tools/netpipe-2.4-ipv6/COPYING;md5=9e3781bb5fe787aa80e1f51f5006b6fa \
17 file://tools/top-LTP/proc/COPYING;md5=aefc88eb8a41672fbfcfe6b69ab8c49c \
18 file://tools/pounder21/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
19 file://utils/benchmark/kernbench-0.42/COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
20 "
21
22DEPENDS = "attr libaio libcap acl openssl"
23
24SRC_URI = "git://github.com/linux-test-project/ltp.git"
25
26SRCREV = "a8c42db5f9314211811c36275a21f83902830dc5"
27S = "${WORKDIR}/git"
28
29export prefix = "/opt/ltp"
30export exec_prefix = "/opt/ltp"
31
32inherit autotools
33
34RDEPENDS_${PN} = "perl e2fsprogs-mke2fs"
35
36FILES_${PN}-dbg += "/opt/ltp/runtest/.debug"
37FILES_${PN}-dbg += "/opt/ltp/testcases/bin/.debug"
38FILES_${PN}-dbg += "/opt/ltp/testcases/bin/*/bin/.debug"
39FILES_${PN}-dbg += "/opt/ltp/testcases/bin/*/test/.debug"
40FILES_${PN}-dbg += "/opt/ltp/scenario_groups/.debug"
41FILES_${PN}-dbg += "/opt/ltp/testscripts/.debug"
42FILES_${PN}-dbg += "/opt/ltp/testscripts/open_posix_testsuite/.debug"
43
44FILES_${PN}-staticdev += "/opt/ltp/lib/libmem.a"
45
46FILES_${PN} += "/opt/ltp/* /opt/ltp/runtest/* /opt/ltp/scenario_groups/* /opt/ltp/testcases/bin/* /opt/ltp/testcases/bin/*/bin/* /opt/ltp/testscripts/* /opt/ltp/testcases/open_posix_testsuite/* /opt/ltp/testcases/open_posix_testsuite/conformance/* /opt/ltp/testcases/open_posix_testsuite/Documentation/* /opt/ltp/testcases/open_posix_testsuite/functional/* /opt/ltp/testcases/open_posix_testsuite/include/* /opt/ltp/testcases/open_posix_testsuite/scripts/* /opt/ltp/testcases/open_posix_testsuite/stress/* /opt/ltp/testcases/open_posix_testsuite/tools/*"
47
48TARGET_CC_ARCH += "${LDFLAGS}"
49
50do_unpack_append() {
51 bb.build.exec_func('do_extract_tarball', d)
52}
53
54do_extract_tarball() {
55 if test -f ${WORKDIR}/ltp-full-${PV} ; then
56 tar x --no-same-owner -f ${WORKDIR}/ltp-full-${PV} -C ${WORKDIR}
57 rm -rf ${WORKDIR}/ltp-${PV}
58 mv ${WORKDIR}/ltp-full-${PV} ${WORKDIR}/ltp-${PV}
59 fi
60}
61
62do_install(){
63 install -d ${D}/opt/ltp/
64 oe_runmake DESTDIR=${D} SKIP_IDCHECK=1 install
65
66 # Copy POSIX test suite into ${D}/opt/ltp/testcases by manual
67 cp -r testcases/open_posix_testsuite ${D}/opt/ltp/testcases
68
69 # We need to remove all scripts which depend on /usr/bin/expect, since expect is not supported in poky
70 # We will add expect for enhancement in future
71 find ${D} -type f -print | xargs grep "\!.*\/usr\/bin\/expect" | awk -F":" '{print $1}' | xargs rm -f
72}
73
74# Avoid generated binaries stripping. Otherwise some of the ltp tests such as ldd01 & nm01 fails
75INHIBIT_PACKAGE_STRIP = "1"