diff options
Diffstat (limited to 'meta/recipes-extended/lsof/lsof_4.88.bb')
-rw-r--r-- | meta/recipes-extended/lsof/lsof_4.88.bb | 53 |
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-extended/lsof/lsof_4.88.bb b/meta/recipes-extended/lsof/lsof_4.88.bb new file mode 100644 index 0000000000..a96b06eae7 --- /dev/null +++ b/meta/recipes-extended/lsof/lsof_4.88.bb | |||
@@ -0,0 +1,53 @@ | |||
1 | SUMMARY = "LiSt Open Files tool" | ||
2 | DESCRIPTION = "Lsof is a Unix-specific diagnostic tool. \ | ||
3 | Its name stands for LiSt Open Files, and it does just that." | ||
4 | SECTION = "devel" | ||
5 | LICENSE = "BSD" | ||
6 | |||
7 | SRC_URI = "ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/lsof_${PV}.tar.bz2" | ||
8 | |||
9 | SRC_URI[md5sum] = "1b29c10db4aa88afcaeeaabeef6790db" | ||
10 | SRC_URI[sha256sum] = "fe6f9b0e26b779ccd0ea5a0b6327c2b5c38d207a6db16f61ac01bd6c44e5c99b" | ||
11 | |||
12 | LOCALSRC = "file://${WORKDIR}/lsof_${PV}/lsof_${PV}_src.tar" | ||
13 | S = "${WORKDIR}/lsof_${PV}_src" | ||
14 | |||
15 | LIC_FILES_CHKSUM = "file://${S}/00README;beginline=645;endline=679;md5=964df275d26429ba3b39dbb9f205172a" | ||
16 | |||
17 | python do_unpack () { | ||
18 | bb.build.exec_func('base_do_unpack', d) | ||
19 | src_uri = d.getVar('SRC_URI') | ||
20 | d.setVar('SRC_URI', '${LOCALSRC}') | ||
21 | bb.build.exec_func('base_do_unpack', d) | ||
22 | d.setVar('SRC_URI', src_uri) | ||
23 | } | ||
24 | |||
25 | export LSOF_OS = "${TARGET_OS}" | ||
26 | LSOF_OS_libc-uclibc = "linux" | ||
27 | LSOF_OS_libc-glibc = "linux" | ||
28 | export LSOF_INCLUDE = "${STAGING_INCDIR}" | ||
29 | |||
30 | do_configure () { | ||
31 | export LSOF_AR="${AR} cr" | ||
32 | export LSOF_RANLIB="${RANLIB}" | ||
33 | if [ "x${GLIBCVERSION}" != "x" ];then | ||
34 | LINUX_CLIB=`echo ${GLIBCVERSION} |sed -e 's,\.,,g'` | ||
35 | LINUX_CLIB="-DGLIBCV=${LINUX_CLIB}" | ||
36 | export LINUX_CLIB | ||
37 | fi | ||
38 | yes | ./Configure ${LSOF_OS} | ||
39 | } | ||
40 | |||
41 | export I = "${STAGING_INCDIR}" | ||
42 | export L = "${STAGING_INCDIR}" | ||
43 | export EXTRA_OEMAKE = "" | ||
44 | |||
45 | do_compile () { | ||
46 | oe_runmake 'CC=${CC}' 'CFGL=${LDFLAGS} -L./lib -llsof' 'DEBUG=' 'INCL=${CFLAGS}' | ||
47 | } | ||
48 | |||
49 | do_install () { | ||
50 | install -d ${D}${sbindir} ${D}${mandir}/man8 | ||
51 | install -m 4755 lsof ${D}${sbindir}/lsof | ||
52 | install -m 0644 lsof.8 ${D}${mandir}/man8/lsof.8 | ||
53 | } | ||