summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsof/lsof_4.86.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/lsof/lsof_4.86.bb')
-rw-r--r--meta/recipes-extended/lsof/lsof_4.86.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/meta/recipes-extended/lsof/lsof_4.86.bb b/meta/recipes-extended/lsof/lsof_4.86.bb
new file mode 100644
index 0000000000..e3f5ef387f
--- /dev/null
+++ b/meta/recipes-extended/lsof/lsof_4.86.bb
@@ -0,0 +1,54 @@
1SUMMARY = "LiSt Open Files tool"
2DESCRIPTION = "Lsof is a Unix-specific diagnostic tool. \
3Its name stands for LiSt Open Files, and it does just that."
4SECTION = "devel"
5LICENSE = "BSD"
6PR = "r0"
7
8SRC_URI = "ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/lsof_${PV}.tar.bz2"
9
10SRC_URI[md5sum] = "9f1cda41f35add068c7b81f873fa56b5"
11SRC_URI[sha256sum] = "13e52b8e87dddf1b2e219004e315d755c659217ce6ffc6a5f1102969f1c4dd0c"
12
13LOCALSRC = "file://${WORKDIR}/lsof_${PV}/lsof_${PV}_src.tar"
14S = "${WORKDIR}/lsof_${PV}_src"
15
16LIC_FILES_CHKSUM = "file://${S}/00README;beginline=645;endline=679;md5=964df275d26429ba3b39dbb9f205172a"
17
18python do_unpack () {
19 bb.build.exec_func('base_do_unpack', d)
20 src_uri = d.getVar('SRC_URI')
21 d.setVar('SRC_URI', '${LOCALSRC}')
22 bb.build.exec_func('base_do_unpack', d)
23 d.setVar('SRC_URI', src_uri)
24}
25
26export LSOF_OS = "${TARGET_OS}"
27LSOF_OS_libc-uclibc = "linux"
28LSOF_OS_libc-glibc = "linux"
29export LSOF_INCLUDE = "${STAGING_INCDIR}"
30
31do_configure () {
32 export LSOF_AR="${AR} cr"
33 export LSOF_RANLIB="${RANLIB}"
34 if [ "x${EGLIBCVERSION}" != "x" ];then
35 LINUX_CLIB=`echo ${EGLIBCVERSION} |sed -e 's,\.,,g'`
36 LINUX_CLIB="-DGLIBCV=${LINUX_CLIB}"
37 export LINUX_CLIB
38 fi
39 yes | ./Configure ${LSOF_OS}
40}
41
42export I = "${STAGING_INCDIR}"
43export L = "${STAGING_INCDIR}"
44export EXTRA_OEMAKE = ""
45
46do_compile () {
47 oe_runmake 'CC=${CC}' 'CFGL=${LDFLAGS} -L./lib -llsof' 'DEBUG=' 'INCL=${CFLAGS}'
48}
49
50do_install () {
51 install -d ${D}${sbindir} ${D}${mandir}/man8
52 install -m 4755 lsof ${D}${sbindir}/lsof
53 install -m 0644 lsof.8 ${D}${mandir}/man8/lsof.8
54}