summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsof/lsof_4.83.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/lsof/lsof_4.83.bb')
-rw-r--r--meta/recipes-extended/lsof/lsof_4.83.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-extended/lsof/lsof_4.83.bb b/meta/recipes-extended/lsof/lsof_4.83.bb
new file mode 100644
index 0000000000..078da64305
--- /dev/null
+++ b/meta/recipes-extended/lsof/lsof_4.83.bb
@@ -0,0 +1,41 @@
1DESCRIPTION = "Lsof is a Unix-specific diagnostic tool. \
2Its name stands for LiSt Open Files, and it does just that."
3SECTION = "devel"
4LICENSE = "BSD"
5
6PR = "r0"
7
8SRC_URI = "ftp://lsof.itap.purdue.edu/pub/tools/unix/lsof/lsof_${PV}.tar.bz2"
9LOCALSRC = "file://${WORKDIR}/lsof_${PV}/lsof_${PV}_src.tar"
10S = "${WORKDIR}/lsof_${PV}_src"
11
12python do_unpack () {
13 bb.build.exec_func('base_do_unpack', d)
14 src_uri = bb.data.getVar('SRC_URI', d)
15 bb.data.setVar('SRC_URI', '${LOCALSRC}', d)
16 bb.build.exec_func('base_do_unpack', d)
17 bb.data.setVar('SRC_URI', src_uri, d)
18}
19
20export LSOF_OS = "${TARGET_OS}"
21LSOF_OS_linux-uclibc = "linux"
22LSOF_OS_linux-gnueabi = "linux"
23export LSOF_INCLUDE = "${STAGING_INCDIR}"
24
25do_configure () {
26 yes | ./Configure ${LSOF_OS}
27}
28
29export I = "${STAGING_INCDIR}"
30export L = "${STAGING_INCDIR}"
31export EXTRA_OEMAKE = ""
32
33do_compile () {
34 oe_runmake 'CC=${CC}' 'CFGL=${LDFLAGS} -L./lib -llsof' 'DEBUG=' 'INCL=${CFLAGS}'
35}
36
37do_install () {
38 install -d ${D}${sbindir} ${D}${mandir}/man8
39 install -m 4755 lsof ${D}${sbindir}/lsof
40 install -m 0644 lsof.8 ${D}${mandir}/man8/lsof.8
41}