summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsb/lsbtest_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/lsb/lsbtest_1.0.bb')
-rw-r--r--meta/recipes-extended/lsb/lsbtest_1.0.bb49
1 files changed, 0 insertions, 49 deletions
diff --git a/meta/recipes-extended/lsb/lsbtest_1.0.bb b/meta/recipes-extended/lsb/lsbtest_1.0.bb
deleted file mode 100644
index a90c023d52..0000000000
--- a/meta/recipes-extended/lsb/lsbtest_1.0.bb
+++ /dev/null
@@ -1,49 +0,0 @@
1SUMMARY = "Automates Linux Standard Base (LSB) tests"
2HOMEPAGE = "https://wiki.debian.org/LSBInitScripts"
3SECTION = "console/utils"
4LICENSE = "GPLv2"
5PR = "r3"
6
7LIC_FILES_CHKSUM = "file://LSB_Test.sh;beginline=3;endline=16;md5=7063bb54b04719df0716b513447f4fc0"
8
9SRC_URI = "file://LSB_Test.sh \
10 file://packages_list \
11 file://session \
12 "
13RDEPENDS_${PN} = "lsb rpm"
14
15S = "${WORKDIR}"
16
17do_install() {
18 install -d ${D}/opt/lsb-test
19 install -m 0755 ${S}/LSB_Test.sh ${D}/opt/lsb-test/LSB_Test.sh
20 install -m 0644 ${S}/packages_list ${D}/opt/lsb-test/packages_list
21 install -m 0644 ${S}/session ${D}/opt/lsb-test/session
22 if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ];then
23 sed -i -e 's/lsbarch/ia32/g' -e 's/targetarch/i486/g' ${D}/opt/lsb-test/packages_list
24 sed -i -e 's/targetarch/x86/g' ${D}/opt/lsb-test/session
25 fi
26 if [ "${TARGET_ARCH}" = "x86_64" ];then
27 sed -i -e 's/lsbarch/amd64/g' -e 's/targetarch/x86_64/g' ${D}/opt/lsb-test/packages_list
28 sed -i -e 's/targetarch/x86-64/g' ${D}/opt/lsb-test/session
29 fi
30 if [ "${TARGET_ARCH}" = "powerpc" ];then
31 sed -i -e 's/lsbarch/ppc32/g' -e 's/targetarch/ppc/g' ${D}/opt/lsb-test/packages_list
32 sed -i -e 's/targetarch/PPC32/g' ${D}/opt/lsb-test/session
33 fi
34
35 # For a ppc64 target. the default userspace is 32b.
36 # Therefore, only change the lsbarch and targetarch
37 # in the package_list when MLIB=lib64 is being used.
38 # Otherwise, by default, the ppc32 LSB packages
39 # will be downloaded by LSB_Test.sh
40 if [ "${TARGET_ARCH}" = "powerpc64" ];then
41 if [ "${PN}" != "${BPN}" ];then
42 sed -i -e 's/lsbarch/ppc64/g' -e 's/targetarch/ppc64/g' ${D}/opt/lsb-test/packages_list
43 sed -i -e 's/targetarch/PPC64/g' ${D}/opt/lsb-test/session
44 fi
45 fi
46}
47
48FILES_${PN} += "/opt/lsb-test/* \
49 "