summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lsb/lsbtest_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/lsb/lsbtest_1.0.bb')
-rw-r--r--meta/recipes-extended/lsb/lsbtest_1.0.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-extended/lsb/lsbtest_1.0.bb b/meta/recipes-extended/lsb/lsbtest_1.0.bb
new file mode 100644
index 0000000000..f61251e2aa
--- /dev/null
+++ b/meta/recipes-extended/lsb/lsbtest_1.0.bb
@@ -0,0 +1,49 @@
1SUMMARY = "Automates Linux Standard Base (LSB) tests"
2SECTION = "console/utils"
3LICENSE = "GPLv2"
4PR = "r3"
5
6LIC_FILES_CHKSUM = "file://LSB_Test.sh;beginline=3;endline=16;md5=7063bb54b04719df0716b513447f4fc0"
7
8SRC_URI = "file://LSB_Test.sh \
9 file://packages_list \
10 file://session \
11 "
12RDEPENDS_${PN} = "rpm"
13
14S = "${WORKDIR}"
15
16do_install() {
17 install -d ${D}${bindir}
18 install -m 0755 ${S}/LSB_Test.sh ${D}${bindir}
19 install -d ${D}/opt/lsb-test
20 install -m 0644 ${S}/packages_list ${D}/opt/lsb-test/packages_list
21 install -m 0644 ${S}/session ${D}/opt/lsb-test/session
22 if [ "${TARGET_ARCH}" = "i586" ];then
23 sed -i -e 's/lsbarch/ia32/g' -e 's/targetarch/i486/g' ${D}/opt/lsb-test/packages_list
24 sed -i -e 's/targetarch/x86/g' ${D}/opt/lsb-test/session
25 fi
26 if [ "${TARGET_ARCH}" = "x86_64" ];then
27 sed -i -e 's/lsbarch/amd64/g' -e 's/targetarch/x86_64/g' ${D}/opt/lsb-test/packages_list
28 sed -i -e 's/targetarch/x86-64/g' ${D}/opt/lsb-test/session
29 fi
30 if [ "${TARGET_ARCH}" = "powerpc" ];then
31 sed -i -e 's/lsbarch/ppc32/g' -e 's/targetarch/ppc/g' ${D}/opt/lsb-test/packages_list
32 sed -i -e 's/targetarch/PPC32/g' ${D}/opt/lsb-test/session
33 fi
34
35 # For a ppc64 target. the default userspace is 32b.
36 # Therefore, only change the lsbarch and targetarch
37 # in the package_list when MLIB=lib64 is being used.
38 # Otherwise, by default, the ppc32 LSB packages
39 # will be downloaded by LSB_Test.sh
40 if [ "${TARGET_ARCH}" = "powerpc64" ];then
41 if [ "${PN}" != "${BPN}" ];then
42 sed -i -e 's/lsbarch/ppc64/g' -e 's/targetarch/ppc64/g' ${D}/opt/lsb-test/packages_list
43 sed -i -e 's/targetarch/PPC64/g' ${D}/opt/lsb-test/session
44 fi
45 fi
46}
47
48FILES_${PN} += "/opt/lsb-test/* \
49 "