diff options
Diffstat (limited to 'meta/recipes-extended/lsb/lsbinitscripts_9.68.bb')
-rw-r--r-- | meta/recipes-extended/lsb/lsbinitscripts_9.68.bb | 33 |
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-extended/lsb/lsbinitscripts_9.68.bb b/meta/recipes-extended/lsb/lsbinitscripts_9.68.bb new file mode 100644 index 0000000000..0c08fffcef --- /dev/null +++ b/meta/recipes-extended/lsb/lsbinitscripts_9.68.bb | |||
@@ -0,0 +1,33 @@ | |||
1 | SUMMARY = "SysV init scripts which are only used in an LSB image" | ||
2 | SECTION = "base" | ||
3 | LICENSE = "GPLv2" | ||
4 | DEPENDS = "popt glib-2.0" | ||
5 | |||
6 | RDEPENDS_${PN} += "util-linux" | ||
7 | |||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=ebf4e8b49780ab187d51bd26aaa022c6" | ||
9 | |||
10 | S="${WORKDIR}/initscripts-${PV}" | ||
11 | SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/initscripts/initscripts-${PV}.tar.bz2/6a51a5af38e01445f53989ed0727c3e1/initscripts-${PV}.tar.bz2 \ | ||
12 | file://functions.patch \ | ||
13 | file://0001-functions-avoid-exit-1-which-causes-init-scripts-to-.patch \ | ||
14 | " | ||
15 | |||
16 | SRC_URI[md5sum] = "6a51a5af38e01445f53989ed0727c3e1" | ||
17 | SRC_URI[sha256sum] = "2a1c6e9dbaa37a676518f4803b501e107c058bb14ef7a8db24c52b77fbcba531" | ||
18 | |||
19 | inherit update-alternatives | ||
20 | |||
21 | ALTERNATIVE_PRIORITY = "100" | ||
22 | ALTERNATIVE_${PN} = "functions" | ||
23 | ALTERNATIVE_LINK_NAME[functions] = "${sysconfdir}/init.d/functions" | ||
24 | |||
25 | # Since we are only taking the patched version of functions, no need to | ||
26 | # configure or compile anything so do not execute these | ||
27 | do_configure[noexec] = "1" | ||
28 | do_compile[noexec] = "1" | ||
29 | |||
30 | do_install(){ | ||
31 | install -d ${D}${sysconfdir}/init.d/ | ||
32 | install -m 0644 ${S}/rc.d/init.d/functions ${D}${sysconfdir}/init.d/functions | ||
33 | } | ||