diff options
Diffstat (limited to 'meta/recipes-extended/lsb/lsb_4.1.bb')
-rw-r--r-- | meta/recipes-extended/lsb/lsb_4.1.bb | 16 |
1 files changed, 3 insertions, 13 deletions
diff --git a/meta/recipes-extended/lsb/lsb_4.1.bb b/meta/recipes-extended/lsb/lsb_4.1.bb index b4ef98eea7..f05c30cd2c 100644 --- a/meta/recipes-extended/lsb/lsb_4.1.bb +++ b/meta/recipes-extended/lsb/lsb_4.1.bb | |||
@@ -72,19 +72,18 @@ do_install(){ | |||
72 | 72 | ||
73 | do_install_append(){ | 73 | do_install_append(){ |
74 | install -d ${D}${sysconfdir}/core-lsb | 74 | install -d ${D}${sysconfdir}/core-lsb |
75 | install -d ${D}/${baselib}/lsb | ||
76 | for i in lsb_killproc lsb_log_message lsb_pidofproc lsb_start_daemon | 75 | for i in lsb_killproc lsb_log_message lsb_pidofproc lsb_start_daemon |
77 | do | 76 | do |
78 | install -m 0755 ${WORKDIR}/${i} ${D}${sysconfdir}/core-lsb | 77 | install -m 0755 ${WORKDIR}/${i} ${D}${sysconfdir}/core-lsb |
79 | done | 78 | done |
80 | install -m 0755 ${WORKDIR}/init-functions ${D}/${baselib}/lsb | 79 | |
80 | install -d ${D}/lib/lsb | ||
81 | install -m 0755 ${WORKDIR}/init-functions ${D}/lib/lsb | ||
81 | 82 | ||
82 | # creat links for LSB test | 83 | # creat links for LSB test |
83 | install -d ${D}/usr/lib/lsb | 84 | install -d ${D}/usr/lib/lsb |
84 | ln -sf ${sbindir}/chkconfig ${D}/usr/lib/lsb/install_initd | 85 | ln -sf ${sbindir}/chkconfig ${D}/usr/lib/lsb/install_initd |
85 | ln -sf ${sbindir}/chkconfig ${D}/usr/lib/lsb/remove_initd | 86 | ln -sf ${sbindir}/chkconfig ${D}/usr/lib/lsb/remove_initd |
86 | install -d ${D}/${libdir} | ||
87 | ln -sf ${sbindir}/sendmail ${D}/${libdir}/sendmail | ||
88 | 87 | ||
89 | if [ "${TARGET_ARCH}" = "x86_64" ];then | 88 | if [ "${TARGET_ARCH}" = "x86_64" ];then |
90 | cd ${D} | 89 | cd ${D} |
@@ -119,13 +118,4 @@ do_install_append(){ | |||
119 | FILES_${PN} += "/lib64 \ | 118 | FILES_${PN} += "/lib64 \ |
120 | /usr/lib/lsb \ | 119 | /usr/lib/lsb \ |
121 | ${base_libdir}/lsb/* \ | 120 | ${base_libdir}/lsb/* \ |
122 | ${libdir}/sendmail \ | ||
123 | " | 121 | " |
124 | |||
125 | # The sysroot/${libdir}/sendmail conflicts with esmtp's, and it's a | ||
126 | # symlink to ${sbindir}/sendmail which is meaningless for sysroot, so | ||
127 | # remove it. | ||
128 | SYSROOT_PREPROCESS_FUNCS += "remove_sysroot_sendmail" | ||
129 | remove_sysroot_sendmail() { | ||
130 | rm -r "${SYSROOT_DESTDIR}${libdir}/sendmail" | ||
131 | } | ||