diff options
Diffstat (limited to 'meta/recipes-extended/lsb/lsb_4.1.bb')
-rw-r--r-- | meta/recipes-extended/lsb/lsb_4.1.bb | 49 |
1 files changed, 25 insertions, 24 deletions
diff --git a/meta/recipes-extended/lsb/lsb_4.1.bb b/meta/recipes-extended/lsb/lsb_4.1.bb index 39cb5445e2..2eb67b8c3a 100644 --- a/meta/recipes-extended/lsb/lsb_4.1.bb +++ b/meta/recipes-extended/lsb/lsb_4.1.bb | |||
@@ -33,10 +33,10 @@ S = "${WORKDIR}/lsb-release-1.4" | |||
33 | 33 | ||
34 | CLEANBROKEN = "1" | 34 | CLEANBROKEN = "1" |
35 | 35 | ||
36 | do_install(){ | 36 | do_install() { |
37 | oe_runmake install prefix=${D}/${base_prefix} mandir=${D}/${datadir}/man/ DESTDIR=${D} | 37 | oe_runmake install prefix=${D}${base_prefix} mandir=${D}${datadir}/man/ DESTDIR=${D} |
38 | 38 | ||
39 | # this 2 dirs are needed by package lsb-dist-checker | 39 | # these two dirs are needed by package lsb-dist-checker |
40 | mkdir -p ${D}${sysconfdir}/opt | 40 | mkdir -p ${D}${sysconfdir}/opt |
41 | mkdir -p ${D}${localstatedir}/opt | 41 | mkdir -p ${D}${localstatedir}/opt |
42 | 42 | ||
@@ -44,7 +44,7 @@ do_install(){ | |||
44 | mkdir -p ${D}${sysconfdir}/lsb-release.d | 44 | mkdir -p ${D}${sysconfdir}/lsb-release.d |
45 | printf "LSB_VERSION=\"core-4.1-noarch:" > ${D}${sysconfdir}/lsb-release | 45 | printf "LSB_VERSION=\"core-4.1-noarch:" > ${D}${sysconfdir}/lsb-release |
46 | 46 | ||
47 | if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ];then | 47 | if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ]; then |
48 | printf "core-4.1-ia32" >> ${D}${sysconfdir}/lsb-release | 48 | printf "core-4.1-ia32" >> ${D}${sysconfdir}/lsb-release |
49 | else | 49 | else |
50 | printf "core-4.1-${TARGET_ARCH}" >> ${D}${sysconfdir}/lsb-release | 50 | printf "core-4.1-${TARGET_ARCH}" >> ${D}${sysconfdir}/lsb-release |
@@ -57,73 +57,74 @@ do_install(){ | |||
57 | fi | 57 | fi |
58 | echo "DISTRIB_DESCRIPTION=\"${DISTRO_NAME} ${DISTRO_VERSION}\"" >> ${D}${sysconfdir}/lsb-release | 58 | echo "DISTRIB_DESCRIPTION=\"${DISTRO_NAME} ${DISTRO_VERSION}\"" >> ${D}${sysconfdir}/lsb-release |
59 | 59 | ||
60 | if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ];then | 60 | if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ]; then |
61 | mkdir -p ${D}${sysconfdir}/lsb-release.d | 61 | mkdir -p ${D}${sysconfdir}/lsb-release.d |
62 | touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-noarch | 62 | touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-noarch |
63 | touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-noarch | 63 | touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-noarch |
64 | touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-ia32 | 64 | touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-ia32 |
65 | touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-ia32 | 65 | touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-ia32 |
66 | elif [ "${TARGET_ARCH}" = "x86_64" ];then | 66 | elif [ "${TARGET_ARCH}" = "x86_64" ]; then |
67 | touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-noarch | 67 | touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-noarch |
68 | touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-amd64 | 68 | touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-amd64 |
69 | touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-amd64 | 69 | touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-amd64 |
70 | fi | 70 | fi |
71 | if [ "${TARGET_ARCH}" = "powerpc" ];then | 71 | if [ "${TARGET_ARCH}" = "powerpc" ]; then |
72 | touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-noarch | 72 | touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-noarch |
73 | touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-ppc32 | 73 | touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-ppc32 |
74 | touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-ppc32 | 74 | touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-ppc32 |
75 | elif [ "${TARGET_ARCH}" = "powerpc64" ];then | 75 | elif [ "${TARGET_ARCH}" = "powerpc64" ]; then |
76 | touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-noarch | 76 | touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-noarch |
77 | touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-ppc64 | 77 | touch ${D}${sysconfdir}/lsb-release.d/graphics-${PV}-ppc64 |
78 | touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-ppc64 | 78 | touch ${D}${sysconfdir}/lsb-release.d/desktop-${PV}-ppc64 |
79 | fi | 79 | fi |
80 | } | 80 | } |
81 | 81 | ||
82 | do_install_append(){ | 82 | do_install_append() { |
83 | install -d ${D}${sysconfdir}/core-lsb | 83 | install -d ${D}${sysconfdir}/core-lsb |
84 | for i in lsb_killproc lsb_log_message lsb_pidofproc lsb_start_daemon | 84 | for i in lsb_killproc lsb_log_message lsb_pidofproc lsb_start_daemon |
85 | do | 85 | do |
86 | install -m 0755 ${WORKDIR}/${i} ${D}${sysconfdir}/core-lsb | 86 | install -m 0755 ${WORKDIR}/$i ${D}${sysconfdir}/core-lsb |
87 | done | 87 | done |
88 | 88 | ||
89 | install -d ${D}/${nonarch_base_libdir}/lsb | 89 | install -d ${D}${nonarch_base_libdir}/lsb |
90 | install -m 0755 ${WORKDIR}/init-functions ${D}/${nonarch_base_libdir}/lsb | 90 | install -m 0755 ${WORKDIR}/init-functions ${D}${nonarch_base_libdir}/lsb |
91 | 91 | ||
92 | # creat links for LSB test | 92 | # create links for LSB test |
93 | if [ "${nonarch_base_libdir}" != "${nonarch_libdir}" ] ; then | 93 | if [ "${nonarch_base_libdir}" != "${nonarch_libdir}" ] ; then |
94 | install -d ${D}/${nonarch_libdir}/lsb | 94 | install -d ${D}${nonarch_libdir}/lsb |
95 | fi | 95 | fi |
96 | ln -sf ${sbindir}/chkconfig ${D}/${nonarch_libdir}/lsb/install_initd | 96 | ln -sf ${sbindir}/chkconfig ${D}${nonarch_libdir}/lsb/install_initd |
97 | ln -sf ${sbindir}/chkconfig ${D}/${nonarch_libdir}/lsb/remove_initd | 97 | ln -sf ${sbindir}/chkconfig ${D}${nonarch_libdir}/lsb/remove_initd |
98 | 98 | ||
99 | if [ "${TARGET_ARCH}" = "x86_64" ];then | 99 | if [ "${TARGET_ARCH}" = "x86_64" ]; then |
100 | if [ "${baselib}" != "lib64" ]; then | 100 | if [ "${baselib}" != "lib64" ]; then |
101 | lnr ${D}${base_libdir} ${D}/lib64 | 101 | lnr ${D}${base_libdir} ${D}/lib64 |
102 | fi | 102 | fi |
103 | cd ${D}/${base_libdir} | 103 | cd ${D}${base_libdir} |
104 | ln -sf ld-linux-x86-64.so.2 ld-lsb-x86-64.so.2 | 104 | ln -sf ld-linux-x86-64.so.2 ld-lsb-x86-64.so.2 |
105 | ln -sf ld-linux-x86-64.so.2 ld-lsb-x86-64.so.3 | 105 | ln -sf ld-linux-x86-64.so.2 ld-lsb-x86-64.so.3 |
106 | fi | 106 | fi |
107 | if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ];then | 107 | if [ "${TARGET_ARCH}" = "i586" ] || [ "${TARGET_ARCH}" = "i686" ]; then |
108 | cd ${D}/${base_libdir} | 108 | cd ${D}${base_libdir} |
109 | ln -sf ld-linux.so.2 ld-lsb.so.2 | 109 | ln -sf ld-linux.so.2 ld-lsb.so.2 |
110 | ln -sf ld-linux.so.2 ld-lsb.so.3 | 110 | ln -sf ld-linux.so.2 ld-lsb.so.3 |
111 | fi | 111 | fi |
112 | 112 | ||
113 | if [ "${TARGET_ARCH}" = "powerpc64" ];then | 113 | if [ "${TARGET_ARCH}" = "powerpc64" ]; then |
114 | if [ "${baselib}" != "lib64" ]; then | 114 | if [ "${baselib}" != "lib64" ]; then |
115 | lnr ${D}${base_libdir} ${D}/lib64 | 115 | lnr ${D}${base_libdir} ${D}/lib64 |
116 | fi | 116 | fi |
117 | cd ${D}/${base_libdir} | 117 | cd ${D}${base_libdir} |
118 | ln -sf ld64.so.1 ld-lsb-ppc64.so.2 | 118 | ln -sf ld64.so.1 ld-lsb-ppc64.so.2 |
119 | ln -sf ld64.so.1 ld-lsb-ppc64.so.3 | 119 | ln -sf ld64.so.1 ld-lsb-ppc64.so.3 |
120 | fi | 120 | fi |
121 | if [ "${TARGET_ARCH}" = "powerpc" ];then | 121 | if [ "${TARGET_ARCH}" = "powerpc" ]; then |
122 | cd ${D}/${base_libdir} | 122 | cd ${D}${base_libdir} |
123 | ln -sf ld.so.1 ld-lsb-ppc32.so.2 | 123 | ln -sf ld.so.1 ld-lsb-ppc32.so.2 |
124 | ln -sf ld.so.1 ld-lsb-ppc32.so.3 | 124 | ln -sf ld.so.1 ld-lsb-ppc32.so.3 |
125 | fi | 125 | fi |
126 | } | 126 | } |
127 | |||
127 | FILES_${PN} += "${@'/lib64' if d.getVar('TARGET_ARCH') == ('x86_64' or 'powerpc64') and '${baselib}' != 'lib64' else ''} \ | 128 | FILES_${PN} += "${@'/lib64' if d.getVar('TARGET_ARCH') == ('x86_64' or 'powerpc64') and '${baselib}' != 'lib64' else ''} \ |
128 | ${base_libdir} \ | 129 | ${base_libdir} \ |
129 | ${nonarch_libdir}/lsb \ | 130 | ${nonarch_libdir}/lsb \ |