summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/logrotate/logrotate_3.8.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/logrotate/logrotate_3.8.8.bb')
-rw-r--r--meta/recipes-extended/logrotate/logrotate_3.8.8.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/meta/recipes-extended/logrotate/logrotate_3.8.8.bb b/meta/recipes-extended/logrotate/logrotate_3.8.8.bb
new file mode 100644
index 0000000000..133f6d7038
--- /dev/null
+++ b/meta/recipes-extended/logrotate/logrotate_3.8.8.bb
@@ -0,0 +1,56 @@
1SUMMARY = "Rotates, compresses, removes and mails system log files"
2SECTION = "console/utils"
3HOMEPAGE = "https://fedorahosted.org/logrotate/"
4LICENSE = "GPLv2"
5
6DEPENDS="coreutils popt"
7
8LIC_FILES_CHKSUM = "file://COPYING;md5=18810669f13b87348459e611d31ab760"
9
10SRC_URI = "https://fedorahosted.org/releases/l/o/logrotate/logrotate-${PV}.tar.gz \
11 file://act-as-mv-when-rotate.patch \
12 file://update-the-manual.patch \
13 file://disable-check-different-filesystems.patch \
14 "
15
16SRC_URI[md5sum] = "49846e873dddea15964cd0355b9943ca"
17SRC_URI[sha256sum] = "46a1510ef4a1f4359edd5f361112cfd1523942e85ff28e6cbb0c81bad1829d0f"
18
19PACKAGECONFIG ?= "\
20 ${@base_contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \
21 ${@base_contains('DISTRO_FEATURES', 'selinux', 'selinux', '', d)} \
22"
23
24# If RPM_OPT_FLAGS is unset, it adds -g itself rather than obeying our
25# optimization variables, so use it rather than EXTRA_CFLAGS.
26EXTRA_OEMAKE = "\
27 LFS= \
28 OS_NAME='${OS_NAME}' \
29 \
30 'CC=${CC}' \
31 'RPM_OPT_FLAGS=${CFLAGS}' \
32 'EXTRA_LDFLAGS=${LDFLAGS}' \
33 \
34 ${@base_contains('PACKAGECONFIG', 'acl', 'WITH_ACL=yes', '', d)} \
35 ${@base_contains('PACKAGECONFIG', 'selinux', 'WITH_SELINUX=yes', '', d)} \
36"
37
38# OS_NAME in the makefile defaults to `uname -s`. The behavior for
39# freebsd/netbsd is questionable, so leave it as Linux, which only sets
40# INSTALL=install and BASEDIR=/usr.
41OS_NAME = "Linux"
42
43do_compile_prepend() {
44 # Make sure the recompile is OK
45 rm -f ${B}/.depend
46}
47
48do_install(){
49 oe_runmake install DESTDIR=${D} PREFIX=${D} MANDIR=${mandir} BINDIR=${bindir}
50 mkdir -p ${D}${sysconfdir}/logrotate.d
51 mkdir -p ${D}${sysconfdir}/cron.daily
52 mkdir -p ${D}${localstatedir}/lib
53 install -p -m 644 examples/logrotate-default ${D}${sysconfdir}/logrotate.conf
54 install -p -m 755 examples/logrotate.cron ${D}${sysconfdir}/cron.daily/logrotate
55 touch ${D}${localstatedir}/lib/logrotate.status
56}