summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lighttpd/lighttpd_1.4.43.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/lighttpd/lighttpd_1.4.43.bb')
-rw-r--r--meta/recipes-extended/lighttpd/lighttpd_1.4.43.bb79
1 files changed, 79 insertions, 0 deletions
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.43.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.43.bb
new file mode 100644
index 0000000000..322f212a73
--- /dev/null
+++ b/meta/recipes-extended/lighttpd/lighttpd_1.4.43.bb
@@ -0,0 +1,79 @@
1SUMMARY = "Lightweight high-performance web server"
2HOMEPAGE = "http://www.lighttpd.net/"
3BUGTRACKER = "http://redmine.lighttpd.net/projects/lighttpd/issues"
4
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579"
7
8SECTION = "net"
9DEPENDS = "zlib libpcre"
10RDEPENDS_${PN} += " \
11 lighttpd-module-access \
12 lighttpd-module-accesslog \
13 lighttpd-module-indexfile \
14 lighttpd-module-dirlisting \
15 lighttpd-module-staticfile \
16"
17
18SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.tar.xz \
19 file://index.html.lighttpd \
20 file://lighttpd.conf \
21 file://lighttpd \
22 file://lighttpd.service \
23 file://0001-Use-pkg-config-for-pcre-dependency-instead-of-config.patch \
24 "
25
26SRC_URI[md5sum] = "95eda531c27b161ef8fa2b9bf4948caf"
27SRC_URI[sha256sum] = "fe0c4a06dd2408a83ee7a2bfedc45e09597f3313cbda82485507573ae8fa948a"
28
29PACKAGECONFIG ??= "openssl \
30 ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \
31"
32PACKAGECONFIG[openssl] = "--with-openssl, --without-openssl, openssl"
33PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
34
35EXTRA_OECONF = " \
36 --without-bzip2 \
37 --without-ldap \
38 --without-lua \
39 --without-memcached \
40 --with-pcre \
41 --without-webdav-props \
42 --without-webdav-locks \
43 --disable-static \
44"
45
46inherit autotools pkgconfig update-rc.d gettext systemd
47
48INITSCRIPT_NAME = "lighttpd"
49INITSCRIPT_PARAMS = "defaults 70"
50
51SYSTEMD_SERVICE_${PN} = "lighttpd.service"
52
53do_install_append() {
54 install -d ${D}${sysconfdir}/init.d ${D}${sysconfdir}/lighttpd.d ${D}/www/pages/dav
55 install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
56 install -m 0644 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
57 install -m 0644 ${WORKDIR}/index.html.lighttpd ${D}/www/pages/index.html
58
59 install -d ${D}${systemd_unitdir}/system
60 install -m 0644 ${WORKDIR}/lighttpd.service ${D}${systemd_unitdir}/system
61 sed -i -e 's,@SBINDIR@,${sbindir},g' \
62 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
63 -e 's,@BASE_BINDIR@,${base_bindir},g' \
64 ${D}${systemd_unitdir}/system/lighttpd.service
65 #For FHS compliance, create symbolic links to /var/log and /var/tmp for logs and temporary data
66 ln -sf ${localstatedir}/log ${D}/www/logs
67 ln -sf ${localstatedir}/tmp ${D}/www/var
68}
69
70FILES_${PN} += "${sysconfdir} /www"
71
72CONFFILES_${PN} = "${sysconfdir}/lighttpd.conf"
73
74PACKAGES_DYNAMIC += "^lighttpd-module-.*"
75
76python populate_packages_prepend () {
77 lighttpd_libdir = d.expand('${libdir}')
78 do_split_packages(d, lighttpd_libdir, '^mod_(.*)\.so$', 'lighttpd-module-%s', 'Lighttpd module for %s', extra_depends='')
79}