diff options
Diffstat (limited to 'meta/recipes-extended/lighttpd/lighttpd_1.4.42.bb')
-rw-r--r-- | meta/recipes-extended/lighttpd/lighttpd_1.4.42.bb | 79 |
1 files changed, 79 insertions, 0 deletions
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.42.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.42.bb new file mode 100644 index 0000000000..43856cac70 --- /dev/null +++ b/meta/recipes-extended/lighttpd/lighttpd_1.4.42.bb | |||
@@ -0,0 +1,79 @@ | |||
1 | SUMMARY = "Lightweight high-performance web server" | ||
2 | HOMEPAGE = "http://www.lighttpd.net/" | ||
3 | BUGTRACKER = "http://redmine.lighttpd.net/projects/lighttpd/issues" | ||
4 | |||
5 | LICENSE = "BSD" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579" | ||
7 | |||
8 | SECTION = "net" | ||
9 | DEPENDS = "zlib libpcre" | ||
10 | RDEPENDS_${PN} += " \ | ||
11 | lighttpd-module-access \ | ||
12 | lighttpd-module-accesslog \ | ||
13 | lighttpd-module-indexfile \ | ||
14 | lighttpd-module-dirlisting \ | ||
15 | lighttpd-module-staticfile \ | ||
16 | " | ||
17 | |||
18 | SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.tar.xz \ | ||
19 | file://index.html.lighttpd \ | ||
20 | file://lighttpd.conf \ | ||
21 | file://lighttpd \ | ||
22 | file://lighttpd.service \ | ||
23 | file://0001-Use-pkg-config-for-pcre-dependency-instead-of-config.patch \ | ||
24 | " | ||
25 | |||
26 | SRC_URI[md5sum] = "53c55d7e1dac7adec161cd5490491f6d" | ||
27 | SRC_URI[sha256sum] = "b2c9069ed0bade9362c27b469a9b884641786aea1c3d686f9fd9f01d15e2a15f" | ||
28 | |||
29 | PACKAGECONFIG ??= "openssl \ | ||
30 | ${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \ | ||
31 | " | ||
32 | PACKAGECONFIG[openssl] = "--with-openssl, --without-openssl, openssl" | ||
33 | PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6," | ||
34 | |||
35 | EXTRA_OECONF = " \ | ||
36 | --without-bzip2 \ | ||
37 | --without-ldap \ | ||
38 | --without-lua \ | ||
39 | --without-memcached \ | ||
40 | --with-pcre \ | ||
41 | --without-webdav-props \ | ||
42 | --without-webdav-locks \ | ||
43 | --disable-static \ | ||
44 | " | ||
45 | |||
46 | inherit autotools pkgconfig update-rc.d gettext systemd | ||
47 | |||
48 | INITSCRIPT_NAME = "lighttpd" | ||
49 | INITSCRIPT_PARAMS = "defaults 70" | ||
50 | |||
51 | SYSTEMD_SERVICE_${PN} = "lighttpd.service" | ||
52 | |||
53 | do_install_append() { | ||
54 | install -d ${D}${sysconfdir}/init.d ${D}${sysconfdir}/lighttpd.d ${D}/www/pages/dav | ||
55 | install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d | ||
56 | install -m 0644 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir} | ||
57 | install -m 0644 ${WORKDIR}/index.html.lighttpd ${D}/www/pages/index.html | ||
58 | |||
59 | install -d ${D}${systemd_unitdir}/system | ||
60 | install -m 0644 ${WORKDIR}/lighttpd.service ${D}${systemd_unitdir}/system | ||
61 | sed -i -e 's,@SBINDIR@,${sbindir},g' \ | ||
62 | -e 's,@SYSCONFDIR@,${sysconfdir},g' \ | ||
63 | -e 's,@BASE_BINDIR@,${base_bindir},g' \ | ||
64 | ${D}${systemd_unitdir}/system/lighttpd.service | ||
65 | #For FHS compliance, create symbolic links to /var/log and /var/tmp for logs and temporary data | ||
66 | ln -sf ${localstatedir}/log ${D}/www/logs | ||
67 | ln -sf ${localstatedir}/tmp ${D}/www/var | ||
68 | } | ||
69 | |||
70 | FILES_${PN} += "${sysconfdir} /www" | ||
71 | |||
72 | CONFFILES_${PN} = "${sysconfdir}/lighttpd.conf" | ||
73 | |||
74 | PACKAGES_DYNAMIC += "^lighttpd-module-.*" | ||
75 | |||
76 | python populate_packages_prepend () { | ||
77 | lighttpd_libdir = d.expand('${libdir}') | ||
78 | do_split_packages(d, lighttpd_libdir, '^mod_(.*)\.so$', 'lighttpd-module-%s', 'Lighttpd module for %s', extra_depends='') | ||
79 | } | ||