summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lighttpd/lighttpd_1.4.35.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/lighttpd/lighttpd_1.4.35.bb')
-rw-r--r--meta/recipes-extended/lighttpd/lighttpd_1.4.35.bb77
1 files changed, 77 insertions, 0 deletions
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.35.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.35.bb
new file mode 100644
index 0000000000..20d5c1caa0
--- /dev/null
+++ b/meta/recipes-extended/lighttpd/lighttpd_1.4.35.bb
@@ -0,0 +1,77 @@
1SUMMARY = "Lightweight high-performance web server"
2HOMEPAGE = "http://www.lighttpd.net/"
3BUGTRACKER = "http://redmine.lighttpd.net/projects/lighttpd/issues"
4
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579"
7
8PR = "r1"
9
10SECTION = "net"
11DEPENDS = "zlib libpcre"
12RDEPENDS_${PN} += " \
13 lighttpd-module-access \
14 lighttpd-module-accesslog \
15 lighttpd-module-indexfile \
16 lighttpd-module-dirlisting \
17 lighttpd-module-staticfile \
18"
19
20
21SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.tar.bz2 \
22 file://index.html.lighttpd \
23 file://lighttpd.conf \
24 file://lighttpd \
25 file://lighttpd.service \
26 file://pkgconfig.patch \
27 "
28
29SRC_URI[md5sum] = "f7a88130ee9984b421ad8aa80629750a"
30SRC_URI[sha256sum] = "4a71c1f6d8af41ed894b507720c4c17184dc320590013881d5170ca7f15c5bf7"
31
32EXTRA_OECONF = " \
33 --without-bzip2 \
34 --without-ldap \
35 --without-lua \
36 --without-memcache \
37 --with-pcre \
38 --without-webdav-props \
39 --without-webdav-locks \
40 --without-openssl \
41 --disable-static \
42"
43
44inherit autotools pkgconfig update-rc.d gettext systemd
45
46INITSCRIPT_NAME = "lighttpd"
47INITSCRIPT_PARAMS = "defaults 70"
48
49SYSTEMD_SERVICE_${PN} = "lighttpd.service"
50
51do_install_append() {
52 install -d ${D}${sysconfdir}/init.d ${D}${sysconfdir}/lighttpd.d ${D}/www/pages/dav
53 install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
54 install -m 0644 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
55 install -m 0644 ${WORKDIR}/index.html.lighttpd ${D}/www/pages/index.html
56
57 install -d ${D}${systemd_unitdir}/system
58 install -m 0644 ${WORKDIR}/lighttpd.service ${D}${systemd_unitdir}/system
59 sed -i -e 's,@SBINDIR@,${sbindir},g' \
60 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
61 -e 's,@BASE_BINDIR@,${base_bindir},g' \
62 ${D}${systemd_unitdir}/system/lighttpd.service
63 #For FHS compliance, create symbolic links to /var/log and /var/tmp for logs and temporary data
64 ln -sf ${localstatedir}/log ${D}/www/logs
65 ln -sf ${localstatedir}/tmp ${D}/www/var
66}
67
68FILES_${PN} += "${sysconfdir} /www"
69
70CONFFILES_${PN} = "${sysconfdir}/lighttpd.conf"
71
72PACKAGES_DYNAMIC += "^lighttpd-module-.*"
73
74python populate_packages_prepend () {
75 lighttpd_libdir = d.expand('${libdir}')
76 do_split_packages(d, lighttpd_libdir, '^mod_(.*)\.so$', 'lighttpd-module-%s', 'Lighttpd module for %s', extra_depends='')
77}