summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lighttpd/lighttpd_1.4.35.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/lighttpd/lighttpd_1.4.35.bb')
-rw-r--r--meta/recipes-extended/lighttpd/lighttpd_1.4.35.bb76
1 files changed, 76 insertions, 0 deletions
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.35.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.35.bb
new file mode 100644
index 0000000000..bcab7d1931
--- /dev/null
+++ b/meta/recipes-extended/lighttpd/lighttpd_1.4.35.bb
@@ -0,0 +1,76 @@
1SUMMARY = "Lightweight high-performance web server"
2HOMEPAGE = "http://www.lighttpd.net/"
3BUGTRACKER = "http://redmine.lighttpd.net/projects/lighttpd/issues"
4
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579"
7
8PR = "r1"
9
10SECTION = "net"
11DEPENDS = "zlib libpcre"
12RDEPENDS_${PN} += " \
13 lighttpd-module-access \
14 lighttpd-module-accesslog \
15 lighttpd-module-indexfile \
16 lighttpd-module-dirlisting \
17 lighttpd-module-staticfile \
18"
19
20
21SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.tar.bz2 \
22 file://index.html.lighttpd \
23 file://lighttpd.conf \
24 file://lighttpd \
25 file://lighttpd.service \
26 "
27
28SRC_URI[md5sum] = "f7a88130ee9984b421ad8aa80629750a"
29SRC_URI[sha256sum] = "4a71c1f6d8af41ed894b507720c4c17184dc320590013881d5170ca7f15c5bf7"
30
31EXTRA_OECONF = " \
32 --without-bzip2 \
33 --without-ldap \
34 --without-lua \
35 --without-memcache \
36 --with-pcre \
37 --without-webdav-props \
38 --without-webdav-locks \
39 --without-openssl \
40 --disable-static \
41"
42
43inherit autotools pkgconfig update-rc.d gettext systemd
44
45INITSCRIPT_NAME = "lighttpd"
46INITSCRIPT_PARAMS = "defaults 70"
47
48SYSTEMD_SERVICE_${PN} = "lighttpd.service"
49
50do_install_append() {
51 install -d ${D}${sysconfdir}/init.d ${D}${sysconfdir}/lighttpd.d ${D}/www/pages/dav
52 install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
53 install -m 0755 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
54 install -m 0644 ${WORKDIR}/index.html.lighttpd ${D}/www/pages/index.html
55
56 install -d ${D}${systemd_unitdir}/system
57 install -m 0644 ${WORKDIR}/lighttpd.service ${D}${systemd_unitdir}/system
58 sed -i -e 's,@SBINDIR@,${sbindir},g' \
59 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
60 -e 's,@BASE_BINDIR@,${base_bindir},g' \
61 ${D}${systemd_unitdir}/system/lighttpd.service
62 #For FHS compliance, create symbolic links to /var/log and /var/tmp for logs and temporary data
63 ln -sf ${localstatedir}/log ${D}/www/logs
64 ln -sf ${localstatedir}/tmp ${D}/www/var
65}
66
67FILES_${PN} += "${sysconfdir} /www"
68
69CONFFILES_${PN} = "${sysconfdir}/lighttpd.conf"
70
71PACKAGES_DYNAMIC += "^lighttpd-module-.*"
72
73python populate_packages_prepend () {
74 lighttpd_libdir = d.expand('${libdir}')
75 do_split_packages(d, lighttpd_libdir, '^mod_(.*)\.so$', 'lighttpd-module-%s', 'Lighttpd module for %s', extra_depends='')
76}