summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lighttpd/lighttpd_1.4.33.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/lighttpd/lighttpd_1.4.33.bb')
-rw-r--r--meta/recipes-extended/lighttpd/lighttpd_1.4.33.bb72
1 files changed, 72 insertions, 0 deletions
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.33.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.33.bb
new file mode 100644
index 0000000000..e8be6594a2
--- /dev/null
+++ b/meta/recipes-extended/lighttpd/lighttpd_1.4.33.bb
@@ -0,0 +1,72 @@
1DESCRIPTION = "Lightweight high-performance web server"
2HOMEPAGE = "http://www.lighttpd.net/"
3BUGTRACKER = "http://redmine.lighttpd.net/projects/lighttpd/issues"
4
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579"
7
8
9SECTION = "net"
10DEPENDS = "zlib libpcre"
11RDEPENDS_${PN} += " \
12 lighttpd-module-access \
13 lighttpd-module-accesslog \
14 lighttpd-module-indexfile \
15 lighttpd-module-dirlisting \
16 lighttpd-module-staticfile \
17"
18
19
20SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.tar.bz2 \
21 file://index.html.lighttpd \
22 file://lighttpd.conf \
23 file://lighttpd \
24 file://lighttpd.service \
25 "
26
27SRC_URI[md5sum] = "e66b8164e5fc5a6beec0823b697fbe1d"
28SRC_URI[sha256sum] = "2ff2324658c0f90e7d39afd40f08f11ca230903b9019c31a2bbecd8f087f235e"
29
30EXTRA_OECONF = " \
31 --without-bzip2 \
32 --without-ldap \
33 --without-lua \
34 --without-memcache \
35 --with-pcre \
36 --without-webdav-props \
37 --without-webdav-locks \
38 --without-openssl \
39 --disable-static \
40"
41
42inherit autotools pkgconfig update-rc.d gettext systemd
43
44INITSCRIPT_NAME = "lighttpd"
45INITSCRIPT_PARAMS = "defaults 70"
46
47SYSTEMD_SERVICE_${PN} = "lighttpd.service"
48
49do_install_append() {
50 install -d ${D}${sysconfdir}/init.d ${D}/www/logs ${D}/www/pages/dav ${D}/www/var
51 install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
52 install -m 0755 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
53 install -m 0644 ${WORKDIR}/index.html.lighttpd ${D}/www/pages/index.html
54
55 install -d ${D}${systemd_unitdir}/system
56 install -m 0644 ${WORKDIR}/lighttpd.service ${D}${systemd_unitdir}/system
57 sed -i -e 's,@SBINDIR@,${sbindir},g' \
58 -e 's,@SYSCONFDIR@,${sysconfdir},g' \
59 -e 's,@BASE_BINDIR@,${base_bindir},g' \
60 ${D}${systemd_unitdir}/system/lighttpd.service
61}
62
63FILES_${PN} += "${sysconfdir} /www"
64
65CONFFILES_${PN} = "${sysconfdir}/lighttpd.conf"
66
67PACKAGES_DYNAMIC += "^lighttpd-module-.*"
68
69python populate_packages_prepend () {
70 lighttpd_libdir = d.expand('${libdir}')
71 do_split_packages(d, lighttpd_libdir, '^mod_(.*)\.so$', 'lighttpd-module-%s', 'Lighttpd module for %s', extra_depends='')
72}