summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/lighttpd/lighttpd_1.4.28.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/lighttpd/lighttpd_1.4.28.bb')
-rw-r--r--meta/recipes-extended/lighttpd/lighttpd_1.4.28.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/meta/recipes-extended/lighttpd/lighttpd_1.4.28.bb b/meta/recipes-extended/lighttpd/lighttpd_1.4.28.bb
new file mode 100644
index 0000000000..f85c3c4dbf
--- /dev/null
+++ b/meta/recipes-extended/lighttpd/lighttpd_1.4.28.bb
@@ -0,0 +1,60 @@
1DESCRIPTION = "Lightweight high-performance web server"
2HOMEPAGE = "http://www.lighttpd.net/"
3BUGTRACKER = "http://redmine.lighttpd.net/projects/lighttpd/issues"
4
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=e4dac5c6ab169aa212feb5028853a579"
7
8
9SECTION = "net"
10DEPENDS = "zlib libpcre"
11RDEPENDS_${PN} += " \
12 lighttpd-module-access \
13 lighttpd-module-accesslog \
14 lighttpd-module-indexfile \
15 lighttpd-module-dirlisting \
16 lighttpd-module-staticfile \
17"
18
19PR = "r0"
20
21SRC_URI = "http://download.lighttpd.net/lighttpd/releases-1.4.x/lighttpd-${PV}.tar.gz;name=src \
22 file://index.html \
23 file://lighttpd.conf \
24 file://lighttpd \
25"
26
27EXTRA_OECONF = " \
28 --without-bzip2 \
29 --without-ldap \
30 --without-lua \
31 --without-memcache \
32 --with-pcre \
33 --without-webdav-props \
34 --without-webdav-locks \
35 --without-openssl \
36 --disable-static \
37"
38
39inherit autotools pkgconfig update-rc.d gettext
40
41INITSCRIPT_NAME = "lighttpd"
42INITSCRIPT_PARAMS = "defaults 70"
43
44do_install_append() {
45 install -d ${D}${sysconfdir}/init.d ${D}/www/logs ${D}/www/pages/dav ${D}/www/var
46 install -m 0755 ${WORKDIR}/lighttpd ${D}${sysconfdir}/init.d
47 install -m 0755 ${WORKDIR}/lighttpd.conf ${D}${sysconfdir}
48 install -m 0644 ${WORKDIR}/index.html ${D}/www/pages/
49}
50
51FILES_${PN} += "${sysconfdir} /www"
52
53CONFFILES_${PN} = "${sysconfdir}/lighttpd.conf"
54
55PACKAGES_DYNAMIC = "lighttpd-module-*"
56
57python populate_packages_prepend () {
58 lighttpd_libdir = bb.data.expand('${libdir}', d)
59 do_split_packages(d, lighttpd_libdir, '^mod_(.*)\.so$', 'lighttpd-module-%s', 'Lighttpd module for %s', extra_depends='')
60}