summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libuser/libuser_0.58.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libuser/libuser_0.58.bb')
-rw-r--r--meta/recipes-extended/libuser/libuser_0.58.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/libuser/libuser_0.58.bb b/meta/recipes-extended/libuser/libuser_0.58.bb
new file mode 100644
index 0000000000..fbd3dd5bdf
--- /dev/null
+++ b/meta/recipes-extended/libuser/libuser_0.58.bb
@@ -0,0 +1,30 @@
1SUMMARY = "user and group account administration library"
2DESCRIPTION = "The libuser library implements a standardized interface for manipulating and administering user \
3and group accounts"
4HOMEPAGE = "https://fedorahosted.org/libuser/"
5BUGTRACKER = "https://fedorahosted.org/libuser/newticket"
6
7LICENSE = "LGPLv2"
8LIC_FILES_CHKSUM = "file://COPYING;md5=5f30f0716dfdd0d91eb439ebec522ec2 \
9 file://lib/user.h;endline=19;md5=76b301f63c39fa992062395efbdc9558 \
10 file://samples/testuser.c;endline=19;md5=3b87fa660fa3f4a6bb31d624afe30ba1"
11
12SECTION = "base"
13
14SRC_URI = "https://fedorahosted.org/releases/l/i/libuser/libuser-${PV}.tar.xz"
15
16SRC_URI[md5sum] = "1fc3ef3f3a3955b2d78562ff4daed793"
17SRC_URI[sha256sum] = "12a0c09d016d80687e04227a00a89e3c056d3b48bfa2444a9028e6474d8e1dbd"
18PR = "r0"
19
20DEPENDS = "popt libpam glib-2.0 xz-native docbook-utils-native linuxdoc-tools-native python"
21
22inherit autotools gettext pythonnative python-dir
23
24EXTRA_OEMAKE = "PYTHON_CPPFLAGS=-I${STAGING_INCDIR}/${PYTHON_DIR}"
25
26PACKAGES += "${PN}-python "
27
28FILES_${PN}-dbg += "${PYTHON_SITEPACKAGES_DIR}/.debug"
29FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR}"
30