summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libtirpc/libtirpc_0.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libtirpc/libtirpc_0.2.2.bb')
-rw-r--r--meta/recipes-extended/libtirpc/libtirpc_0.2.2.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-extended/libtirpc/libtirpc_0.2.2.bb b/meta/recipes-extended/libtirpc/libtirpc_0.2.2.bb
new file mode 100644
index 0000000000..f1f66e3ebf
--- /dev/null
+++ b/meta/recipes-extended/libtirpc/libtirpc_0.2.2.bb
@@ -0,0 +1,33 @@
1SUMMARY = "Transport-Independent RPC library"
2DESCRIPTION = "Libtirpc is a port of Suns Transport-Independent RPC library to Linux"
3SECTION = "libs/network"
4PRIORITY = "optional"
5HOMEPAGE = "http://sourceforge.net/projects/libtirpc/"
6BUGTRACKER = "http://sourceforge.net/tracker/?group_id=183075&atid=903784"
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=f835cce8852481e4b2bbbdd23b5e47f3 \
9 file://src/netname.c;beginline=1;endline=27;md5=f8a8cd2cb25ac5aa16767364fb0e3c24"
10PR = "r0"
11
12DEPENDS += "xz-native"
13PROVIDES = "virtual/librpc"
14
15SRC_URI = "${SOURCEFORGE_MIRROR}/${PN}/${P}.tar.bz2;name=libtirpc \
16 ${GENTOO_MIRROR}/${PN}-glibc-nfs.tar.xz;name=glibc-nfs \
17 file://libtirpc-0.2.1-fortify.patch \
18 file://libtirpc-0.2.2-rpc-des-prot.patch \
19 file://remove-des-crypt.patch \
20 "
21SRC_URI[libtirpc.md5sum] = "74c41c15c2909f7d11d9c7bfa7db6273"
22SRC_URI[libtirpc.sha256sum] = "f05eb17c85d62423858b8f74512cfe66a9ae1cedf93f03c2a0a32e04f0a33705"
23SRC_URI[glibc-nfs.md5sum] = "5ae500b9d0b6b72cb875bc04944b9445"
24SRC_URI[glibc-nfs.sha256sum] = "2677cfedf626f3f5a8f6e507aed5bb8f79a7453b589d684dbbc086e755170d83"
25inherit autotools pkgconfig
26
27do_configure_prepend () {
28 cp -r ${S}/../tirpc ${S}
29}
30
31do_install_append() {
32 chown root:root ${D}${sysconfdir}/netconfig
33}