summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libsolv/libsolv_0.7.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libsolv/libsolv_0.7.4.bb')
-rw-r--r--meta/recipes-extended/libsolv/libsolv_0.7.4.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-extended/libsolv/libsolv_0.7.4.bb b/meta/recipes-extended/libsolv/libsolv_0.7.4.bb
new file mode 100644
index 0000000000..b8653adc01
--- /dev/null
+++ b/meta/recipes-extended/libsolv/libsolv_0.7.4.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Library for solving packages and reading repositories"
2HOMEPAGE = "https://github.com/openSUSE/libsolv"
3BUGTRACKER = "https://github.com/openSUSE/libsolv/issues"
4SECTION = "devel"
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8"
7
8DEPENDS = "expat zlib"
9
10SRC_URI = "git://github.com/openSUSE/libsolv.git \
11 file://0001-build-use-GNUInstallDirs.patch \
12"
13
14SRCREV = "51fc3b1214aa9677e972712fa1ce6916e438751f"
15
16UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
17
18S = "${WORKDIR}/git"
19
20inherit cmake
21
22PACKAGECONFIG ??= "rpm"
23PACKAGECONFIG[rpm] = "-DENABLE_RPMMD=ON -DENABLE_RPMDB=ON,,rpm"
24
25EXTRA_OECMAKE = "-DMULTI_SEMANTICS=ON -DENABLE_COMPLEX_DEPS=ON"
26
27PACKAGES =+ "${PN}-tools ${PN}ext"
28
29FILES_${PN}-tools = "${bindir}/*"
30FILES_${PN}ext = "${libdir}/${PN}ext.so.*"
31
32BBCLASSEXTEND = "native nativesdk"