summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libsolv/libsolv_0.7.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libsolv/libsolv_0.7.3.bb')
-rw-r--r--meta/recipes-extended/libsolv/libsolv_0.7.3.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-extended/libsolv/libsolv_0.7.3.bb b/meta/recipes-extended/libsolv/libsolv_0.7.3.bb
new file mode 100644
index 0000000000..7321d63374
--- /dev/null
+++ b/meta/recipes-extended/libsolv/libsolv_0.7.3.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Library for solving packages and reading repositories"
2HOMEPAGE = "https://github.com/openSUSE/libsolv"
3BUGTRACKER = "https://github.com/openSUSE/libsolv/issues"
4SECTION = "devel"
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8"
7
8DEPENDS = "expat zlib"
9
10SRC_URI = "git://github.com/openSUSE/libsolv.git"
11SRC_URI_append_libc-musl = " file://0001-Add-fallback-fopencookie-implementation.patch \
12 file://0002-Fixes-to-internal-fopencookie-implementation.patch \
13 "
14
15SRCREV = "dc7d0f1c3113f2c8217563166906bef3eb5d1ee1"
16UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
17
18S = "${WORKDIR}/git"
19
20inherit cmake
21
22PACKAGECONFIG ??= "rpm"
23PACKAGECONFIG[rpm] = "-DENABLE_RPMMD=ON -DENABLE_RPMDB=ON,,rpm"
24
25EXTRA_OECMAKE = "-DLIB=${baselib} -DMULTI_SEMANTICS=ON -DENABLE_COMPLEX_DEPS=ON"
26
27PACKAGES =+ "${PN}-tools ${PN}ext"
28
29FILES_${PN}-tools = "${bindir}/*"
30FILES_${PN}ext = "${libdir}/${PN}ext.so.*"
31
32BBCLASSEXTEND = "native nativesdk"