summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libsolv/libsolv_0.6.33.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libsolv/libsolv_0.6.33.bb')
-rw-r--r--meta/recipes-extended/libsolv/libsolv_0.6.33.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-extended/libsolv/libsolv_0.6.33.bb b/meta/recipes-extended/libsolv/libsolv_0.6.33.bb
new file mode 100644
index 0000000000..0401ced24a
--- /dev/null
+++ b/meta/recipes-extended/libsolv/libsolv_0.6.33.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Library for solving packages and reading repositories"
2HOMEPAGE = "https://github.com/openSUSE/libsolv"
3BUGTRACKER = "https://github.com/openSUSE/libsolv/issues"
4SECTION = "devel"
5LICENSE = "BSD-3-Clause"
6LIC_FILES_CHKSUM = "file://LICENSE.BSD;md5=62272bd11c97396d4aaf1c41bc11f7d8"
7
8DEPENDS = "expat zlib rpm"
9
10SRC_URI = "git://github.com/openSUSE/libsolv.git \
11 "
12SRC_URI_append_libc-musl = " file://0001-Add-fallback-fopencookie-implementation.patch \
13 file://0002-Fixes-to-internal-fopencookie-implementation.patch \
14 "
15
16SRCREV = "69f1803978ba7a46a57928fa4be6430792419e4e"
17UPSTREAM_CHECK_GITTAGREGEX = "(?P<pver>\d+(\.\d+)+)"
18
19S = "${WORKDIR}/git"
20
21inherit cmake
22
23EXTRA_OECMAKE = "-DLIB=${baselib} -DMULTI_SEMANTICS=ON -DENABLE_RPMMD=ON -DENABLE_RPMDB=ON -DENABLE_COMPLEX_DEPS=ON"
24
25PACKAGES =+ "${PN}-tools ${PN}ext"
26
27FILES_${PN}-tools = "${bindir}/*"
28FILES_${PN}ext = "${libdir}/${PN}ext.so.*"
29
30BBCLASSEXTEND = "native nativesdk"