summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libidn/libidn_1.33.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libidn/libidn_1.33.bb')
-rw-r--r--meta/recipes-extended/libidn/libidn_1.33.bb42
1 files changed, 42 insertions, 0 deletions
diff --git a/meta/recipes-extended/libidn/libidn_1.33.bb b/meta/recipes-extended/libidn/libidn_1.33.bb
new file mode 100644
index 0000000000..26cabd6f10
--- /dev/null
+++ b/meta/recipes-extended/libidn/libidn_1.33.bb
@@ -0,0 +1,42 @@
1SUMMARY = "Internationalized Domain Name support library"
2DESCRIPTION = "Implementation of the Stringprep, Punycode and IDNA specifications defined by the IETF Internationalized Domain Names (IDN) working group."
3HOMEPAGE = "http://www.gnu.org/software/libidn/"
4SECTION = "libs"
5LICENSE = "(LGPLv2.1+ | LGPLv3) & GPLv3+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=df4be47940a91ee69556f5f71eed4aec \
7 file://COPYING.LESSERv2;md5=4fbd65380cdd255951079008b364516c \
8 file://COPYING.LESSERv3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
9 file://COPYINGv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
10 file://COPYINGv3;md5=d32239bcb673463ab874e80d47fae504 \
11 file://lib/idna.h;endline=21;md5=37cffad24807f446a24de3e7371f20b9 \
12 file://src/idn.c;endline=20;md5=09e97034a8877b3451cb65065fc2c06e"
13DEPENDS = "virtual/libiconv"
14
15inherit pkgconfig autotools gettext texinfo
16
17SRC_URI = "${GNU_MIRROR}/libidn/${BPN}-${PV}.tar.gz \
18 file://libidn_fix_for_automake-1.12.patch \
19 file://avoid_AM_PROG_MKDIR_P_warning_error_with_automake_1.12.patch \
20 file://dont-depend-on-help2man.patch \
21 file://0001-idn-fix-printf-format-security-warnings.patch \
22"
23
24SRC_URI[md5sum] = "a9aa7e003665de9c82bd3f9fc6ccf308"
25SRC_URI[sha256sum] = "44a7aab635bb721ceef6beecc4d49dfd19478325e1b47f3196f7d2acc4930e19"
26
27# command tool is under GPLv3+, while libidn itself is under LGPLv2.1+ or LGPLv3
28# so package command into a separate package
29PACKAGES =+ "idn"
30FILES_idn = "${bindir}/*"
31
32LICENSE_${PN} = "LGPLv2.1+ | LGPLv3"
33LICENSE_idn = "GPLv3+"
34
35EXTRA_OECONF = "--disable-csharp"
36
37do_install_append() {
38 rm -rf ${D}${datadir}/emacs
39}
40
41BBCLASSEXTEND = "native nativesdk"
42