summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libidn/libidn_1.29.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libidn/libidn_1.29.bb')
-rw-r--r--meta/recipes-extended/libidn/libidn_1.29.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-extended/libidn/libidn_1.29.bb b/meta/recipes-extended/libidn/libidn_1.29.bb
new file mode 100644
index 0000000000..04b534474d
--- /dev/null
+++ b/meta/recipes-extended/libidn/libidn_1.29.bb
@@ -0,0 +1,34 @@
1SUMMARY = "Internationalized Domain Name support library"
2DESCRIPTION = "Implementation of the Stringprep, Punycode and IDNA specifications defined by the IETF Internationalized Domain Names (IDN) working group."
3HOMEPAGE = "http://www.gnu.org/software/libidn/"
4SECTION = "libs"
5LICENSE = "(LGPLv2.1+ | LGPLv3) & GPLv3+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b35f8839295dd730a55f1a19ec086217 \
7 file://COPYING.LESSERv2;md5=4fbd65380cdd255951079008b364516c \
8 file://COPYING.LESSERv3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
9 file://COPYINGv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
10 file://COPYINGv3;md5=d32239bcb673463ab874e80d47fae504 \
11 file://lib/idna.h;endline=21;md5=61a0e126c0c5552290d9bfa57e407dd6 \
12 file://src/idn.c;endline=20;md5=3f55c28bede16bd7b1244be73067d195"
13
14inherit pkgconfig autotools gettext texinfo
15
16SRC_URI = "${GNU_MIRROR}/libidn/${BPN}-${PV}.tar.gz \
17 file://libidn_fix_for_automake-1.12.patch \
18 file://avoid_AM_PROG_MKDIR_P_warning_error_with_automake_1.12.patch \
19 file://dont-depend-on-help2man.patch \
20"
21
22SRC_URI[md5sum] = "2b67bb507207af379f9461e1307dc84b"
23SRC_URI[sha256sum] = "fb82747dbbf9b36f703ed27293317d818d7e851d4f5773dedf3efa4db32a7c7c"
24
25# command tool is under GPLv3+, while libidn itself is under LGPLv2.1+ or LGPLv3
26# so package command into a separate package
27PACKAGES =+ "idn"
28FILES_idn = "${bindir}/*"
29
30EXTRA_OECONF = "--disable-csharp"
31
32do_install_append() {
33 rm -rf ${D}${datadir}/emacs
34}