summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libidn/libidn_0.6.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libidn/libidn_0.6.14.bb')
-rw-r--r--meta/recipes-extended/libidn/libidn_0.6.14.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta/recipes-extended/libidn/libidn_0.6.14.bb b/meta/recipes-extended/libidn/libidn_0.6.14.bb
new file mode 100644
index 0000000000..17bb103d9e
--- /dev/null
+++ b/meta/recipes-extended/libidn/libidn_0.6.14.bb
@@ -0,0 +1,26 @@
1DESCRIPTION = "Implementation of the Stringprep, Punycode and IDNA specifications defined by the IETF Internationalized Domain Names (IDN) working group."
2HOMEPAGE = "http://www.gnu.org/software/libidn/"
3SECTION = "libs"
4LICENSE = "LGPLv2.1+ & GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a \
6 file://COPYING.LIB;md5=a6f89e2100d9b6cdffcea4f398e37343 \
7 file://lib/idna.h;firstline=6;endline=18;md5=6d9d5532eb28b99e860262281c540d02 \
8 file://src/idn.c;firstline=6;endline=18;md5=41b6aec531cc6a9d54a6c4deee251bf5"
9PR = "r0"
10
11inherit pkgconfig autotools gettext
12
13SRC_URI = "http://alpha.gnu.org/gnu/libidn/${P}.tar.gz"
14
15EXTRA_OECONF = " --disable-tld"
16
17do_configure_prepend() {
18 # this version of libidn copies AC_USE_SYSTEM_EXTENSIONS from
19 # autoconf CVS because atm the autoconf it uses is a bit old
20 # now with cross autotool, that macro is already there and this
21 # local definition causes circular dependency. Actually AC_GNU_SOURCE
22 # is identical to AC_USE_SYSTEM_EXTENSIONS. So remove all local
23 # references to the latter here.
24 sed -i -e "/AC_REQUIRE(\[gl_USE_SYSTEM_EXTENSIONS/d" ${S}/lib/gl/m4/gnulib-comp.m4
25 rm -f ${S}/lib/gl/m4/extensions.m4
26}