summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libidn/libidn2_2.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libidn/libidn2_2.3.1.bb')
-rw-r--r--meta/recipes-extended/libidn/libidn2_2.3.1.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-extended/libidn/libidn2_2.3.1.bb b/meta/recipes-extended/libidn/libidn2_2.3.1.bb
new file mode 100644
index 0000000000..d33d6a7dab
--- /dev/null
+++ b/meta/recipes-extended/libidn/libidn2_2.3.1.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Internationalized Domain Name support library"
2DESCRIPTION = "Implementation of the Stringprep, Punycode and IDNA specifications defined by the IETF Internationalized Domain Names (IDN) working group."
3HOMEPAGE = "http://www.gnu.org/software/libidn/"
4SECTION = "libs"
5LICENSE = "(GPLv2+ | LGPLv3) & GPLv3+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=2d834ea7d480438ada04e5d846152395 \
7 file://COPYING.LESSERv3;md5=e6a600fd5e1d9cbde2d983680233ad02 \
8 file://COPYINGv2;md5=b234ee4d69f5fce4486a80fdaf4a4263 \
9 file://src/idn2.c;endline=16;md5=e4b6d628a84a55f1fd8ae4c76c5f6509 \
10 file://lib/idn2.h.in;endline=27;md5=d0fc8ec628be130a1d5b889107e92477"
11
12SRC_URI = "${GNU_MIRROR}/libidn/${BPN}-${PV}.tar.gz"
13SRC_URI[md5sum] = "cda07f5ac55fccfafdf7ee01828adad5"
14SRC_URI[sha256sum] = "8af684943836b8b53965d5f5b6714ef13c26c91eaa36ce7d242e3d21f5d40f2d"
15
16DEPENDS = "virtual/libiconv libunistring"
17
18inherit pkgconfig autotools gettext texinfo gtk-doc lib_package
19
20EXTRA_OECONF += "--disable-rpath \
21 --with-libunistring-prefix=${STAGING_EXECPREFIXDIR} \
22 "
23
24do_install_append() {
25 # Need to remove any duplicate whitespace too for reproducibility
26 sed -i -e 's|-L${STAGING_LIBDIR}||' -e 's/ */ /g' ${D}${libdir}/pkgconfig/libidn2.pc
27}
28
29LICENSE_${PN} = "(GPLv2+ | LGPLv3)"
30LICENSE_${PN}-bin = "GPLv3+"
31
32BBCLASSEXTEND = "native nativesdk"