diff options
Diffstat (limited to 'meta/recipes-extended/libarchive/libarchive_3.5.3.bb')
-rw-r--r-- | meta/recipes-extended/libarchive/libarchive_3.5.3.bb | 66 |
1 files changed, 66 insertions, 0 deletions
diff --git a/meta/recipes-extended/libarchive/libarchive_3.5.3.bb b/meta/recipes-extended/libarchive/libarchive_3.5.3.bb new file mode 100644 index 0000000000..dd607aca0a --- /dev/null +++ b/meta/recipes-extended/libarchive/libarchive_3.5.3.bb | |||
@@ -0,0 +1,66 @@ | |||
1 | SUMMARY = "Support for reading various archive formats" | ||
2 | DESCRIPTION = "C library and command-line tools for reading and writing tar, cpio, zip, ISO, and other archive formats" | ||
3 | HOMEPAGE = "http://www.libarchive.org/" | ||
4 | SECTION = "devel" | ||
5 | LICENSE = "BSD-2-Clause" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=d499814247adaee08d88080841cb5665" | ||
7 | |||
8 | DEPENDS = "e2fsprogs-native" | ||
9 | |||
10 | PACKAGECONFIG ?= "zlib bz2 xz lzo zstd" | ||
11 | |||
12 | PACKAGECONFIG:append:class-target = "\ | ||
13 | ${@bb.utils.filter('DISTRO_FEATURES', 'acl xattr', d)} \ | ||
14 | " | ||
15 | |||
16 | DEPENDS_BZIP2 = "bzip2-replacement-native" | ||
17 | DEPENDS_BZIP2:class-target = "bzip2" | ||
18 | |||
19 | PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl," | ||
20 | PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr," | ||
21 | PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib," | ||
22 | PACKAGECONFIG[bz2] = "--with-bz2lib,--without-bz2lib,${DEPENDS_BZIP2}," | ||
23 | PACKAGECONFIG[xz] = "--with-lzma,--without-lzma,xz," | ||
24 | PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl," | ||
25 | PACKAGECONFIG[libxml2] = "--with-xml2,--without-xml2,libxml2," | ||
26 | PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat," | ||
27 | PACKAGECONFIG[lzo] = "--with-lzo2,--without-lzo2,lzo," | ||
28 | PACKAGECONFIG[nettle] = "--with-nettle,--without-nettle,nettle," | ||
29 | PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4," | ||
30 | PACKAGECONFIG[mbedtls] = "--with-mbedtls,--without-mbedtls,mbedtls," | ||
31 | PACKAGECONFIG[zstd] = "--with-zstd,--without-zstd,zstd," | ||
32 | |||
33 | EXTRA_OECONF += "--enable-largefile" | ||
34 | |||
35 | SRC_URI = "http://libarchive.org/downloads/libarchive-${PV}.tar.gz" | ||
36 | |||
37 | SRC_URI[sha256sum] = "72788e5f58d16febddfa262a5215e05fc9c79f2670f641ac039e6df44330ef51" | ||
38 | |||
39 | inherit autotools update-alternatives pkgconfig | ||
40 | |||
41 | CPPFLAGS += "-I${WORKDIR}/extra-includes" | ||
42 | |||
43 | do_configure[cleandirs] += "${WORKDIR}/extra-includes" | ||
44 | do_configure:prepend() { | ||
45 | # We just need the headers for some type constants, so no need to | ||
46 | # build all of e2fsprogs for the target | ||
47 | cp -R ${STAGING_INCDIR_NATIVE}/ext2fs ${WORKDIR}/extra-includes/ | ||
48 | } | ||
49 | |||
50 | ALTERNATIVE_PRIORITY = "80" | ||
51 | |||
52 | PACKAGES =+ "bsdtar" | ||
53 | FILES:bsdtar = "${bindir}/bsdtar" | ||
54 | |||
55 | ALTERNATIVE:bsdtar = "tar" | ||
56 | ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar" | ||
57 | ALTERNATIVE_TARGET[tar] = "${bindir}/bsdtar" | ||
58 | |||
59 | PACKAGES =+ "bsdcpio" | ||
60 | FILES:bsdcpio = "${bindir}/bsdcpio" | ||
61 | |||
62 | ALTERNATIVE:bsdcpio = "cpio" | ||
63 | ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio" | ||
64 | ALTERNATIVE_TARGET[cpio] = "${bindir}/bsdcpio" | ||
65 | |||
66 | BBCLASSEXTEND = "native nativesdk" | ||