summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libarchive/libarchive_3.5.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libarchive/libarchive_3.5.3.bb')
-rw-r--r--meta/recipes-extended/libarchive/libarchive_3.5.3.bb66
1 files changed, 66 insertions, 0 deletions
diff --git a/meta/recipes-extended/libarchive/libarchive_3.5.3.bb b/meta/recipes-extended/libarchive/libarchive_3.5.3.bb
new file mode 100644
index 0000000000..92bb223784
--- /dev/null
+++ b/meta/recipes-extended/libarchive/libarchive_3.5.3.bb
@@ -0,0 +1,66 @@
1SUMMARY = "Support for reading various archive formats"
2DESCRIPTION = "C library and command-line tools for reading and writing tar, cpio, zip, ISO, and other archive formats"
3HOMEPAGE = "http://www.libarchive.org/"
4SECTION = "devel"
5LICENSE = "BSD-2-Clause"
6LIC_FILES_CHKSUM = "file://COPYING;md5=d499814247adaee08d88080841cb5665"
7
8DEPENDS = "e2fsprogs-native"
9
10PACKAGECONFIG ?= "zlib bz2 xz lzo"
11
12PACKAGECONFIG_append_class-target = "\
13 libxml2 \
14 ${@bb.utils.filter('DISTRO_FEATURES', 'acl xattr', d)} \
15"
16
17DEPENDS_BZIP2 = "bzip2-replacement-native"
18DEPENDS_BZIP2_class-target = "bzip2"
19
20PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
21PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"
22PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib,"
23PACKAGECONFIG[bz2] = "--with-bz2lib,--without-bz2lib,${DEPENDS_BZIP2},"
24PACKAGECONFIG[xz] = "--with-lzma,--without-lzma,xz,"
25PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl,"
26PACKAGECONFIG[libxml2] = "--with-xml2,--without-xml2,libxml2,"
27PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat,"
28PACKAGECONFIG[lzo] = "--with-lzo2,--without-lzo2,lzo,"
29PACKAGECONFIG[nettle] = "--with-nettle,--without-nettle,nettle,"
30PACKAGECONFIG[lz4] = "--with-lz4,--without-lz4,lz4,"
31PACKAGECONFIG[mbedtls] = "--with-mbedtls,--without-mbedtls,mbedtls,"
32
33EXTRA_OECONF += "--enable-largefile"
34
35SRC_URI = "http://libarchive.org/downloads/libarchive-${PV}.tar.gz"
36
37SRC_URI[sha256sum] = "72788e5f58d16febddfa262a5215e05fc9c79f2670f641ac039e6df44330ef51"
38
39inherit autotools update-alternatives pkgconfig
40
41CPPFLAGS += "-I${WORKDIR}/extra-includes"
42
43do_configure[cleandirs] += "${WORKDIR}/extra-includes"
44do_configure_prepend() {
45 # We just need the headers for some type constants, so no need to
46 # build all of e2fsprogs for the target
47 cp -R ${STAGING_INCDIR_NATIVE}/ext2fs ${WORKDIR}/extra-includes/
48}
49
50ALTERNATIVE_PRIORITY = "80"
51
52PACKAGES =+ "bsdtar"
53FILES_bsdtar = "${bindir}/bsdtar"
54
55ALTERNATIVE_bsdtar = "tar"
56ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
57ALTERNATIVE_TARGET[tar] = "${bindir}/bsdtar"
58
59PACKAGES =+ "bsdcpio"
60FILES_bsdcpio = "${bindir}/bsdcpio"
61
62ALTERNATIVE_bsdcpio = "cpio"
63ALTERNATIVE_LINK_NAME[cpio] = "${base_bindir}/cpio"
64ALTERNATIVE_TARGET[cpio] = "${bindir}/bsdcpio"
65
66BBCLASSEXTEND = "native nativesdk"