summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/libarchive/libarchive_3.1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/libarchive/libarchive_3.1.2.bb')
-rw-r--r--meta/recipes-extended/libarchive/libarchive_3.1.2.bb51
1 files changed, 51 insertions, 0 deletions
diff --git a/meta/recipes-extended/libarchive/libarchive_3.1.2.bb b/meta/recipes-extended/libarchive/libarchive_3.1.2.bb
new file mode 100644
index 0000000000..96e2d500ed
--- /dev/null
+++ b/meta/recipes-extended/libarchive/libarchive_3.1.2.bb
@@ -0,0 +1,51 @@
1SUMMARY = "Support for reading various archive formats"
2DESCRIPTION = "C library and command-line tools for reading and writing tar, cpio, zip, ISO, and other archive formats"
3HOMEPAGE = "http://www.libarchive.org/"
4SECTION = "devel"
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=b4e3ffd607d6686c6cb2f63394370841"
7
8DEPENDS = "e2fsprogs-native"
9
10PACKAGECONFIG ?= "libxml2 zlib bz2"
11
12PACKAGECONFIG_append_class-target = "\
13 ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \
14 ${@bb.utils.contains('DISTRO_FEATURES', 'xattr', 'xattr', '', d)} \
15 ${@bb.utils.contains('DISTRO_FEATURES', 'largefile', 'largefile', '', d)} \
16"
17
18PACKAGECONFIG_append_class-nativesdk = " largefile"
19
20PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl,"
21PACKAGECONFIG[xattr] = "--enable-xattr,--disable-xattr,attr,"
22PACKAGECONFIG[largefile] = "--enable-largefile,--disable-largefile,,"
23PACKAGECONFIG[zlib] = "--with-zlib,--without-zlib,zlib,"
24PACKAGECONFIG[bz2] = "--with-bz2lib,--without-bz2lib,bzip2,"
25PACKAGECONFIG[xz] = "--with-lzmadec --with-lzma,--without-lzmadec --without-lzma,xz,"
26PACKAGECONFIG[openssl] = "--with-openssl,--without-openssl,openssl,"
27PACKAGECONFIG[libxml2] = "--with-xml2,--without-xml2,libxml2,"
28PACKAGECONFIG[expat] = "--with-expat,--without-expat,expat,"
29PACKAGECONFIG[lzo] = "--with-lzo2,--without-lzo2,lzo,"
30PACKAGECONFIG[nettle] = "--with-nettle,--without-nettle,nettle,"
31
32SRC_URI = "http://libarchive.org/downloads/libarchive-${PV}.tar.gz \
33 file://libarchive-CVE-2013-0211.patch \
34 file://pkgconfig.patch \
35 "
36
37SRC_URI[md5sum] = "efad5a503f66329bb9d2f4308b5de98a"
38SRC_URI[sha256sum] = "eb87eacd8fe49e8d90c8fdc189813023ccc319c5e752b01fb6ad0cc7b2c53d5e"
39
40inherit autotools-brokensep lib_package pkgconfig
41
42CPPFLAGS += "-I${WORKDIR}/extra-includes"
43
44do_configure[cleandirs] += "${WORKDIR}/extra-includes"
45do_configure_prepend() {
46 # We just need the headers for some type constants, so no need to
47 # build all of e2fsprogs for the target
48 cp -R ${STAGING_INCDIR_NATIVE}/ext2fs ${WORKDIR}/extra-includes/
49}
50
51BBCLASSEXTEND = "native nativesdk"