summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/less/less_466.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/less/less_466.bb')
-rw-r--r--meta/recipes-extended/less/less_466.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-extended/less/less_466.bb b/meta/recipes-extended/less/less_466.bb
new file mode 100644
index 0000000000..c5b8a3f7b6
--- /dev/null
+++ b/meta/recipes-extended/less/less_466.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Text file viewer similar to more"
2DESCRIPTION = "Less is a program similar to more, i.e. a terminal \
3based program for viewing text files and the output from other \
4programs. Less offers many features beyond those that more does."
5HOMEPAGE = "http://www.greenwoodsoftware.com/"
6SECTION = "console/utils"
7
8# (GPLv2+ (<< 418), GPLv3+ (>= 418)) | less
9# Including email author giving permissing to use BSD
10#
11# From: Mark Nudelman <markn@greenwoodsoftware.com>
12# To: Elizabeth Flanagan <elizabeth.flanagan@intel.com
13# Date: 12/19/11
14#
15# Hi Elizabeth,
16# Using a generic BSD license for less is fine with me.
17# Thanks,
18#
19# --Mark
20#
21
22LICENSE = "GPLv3+ | BSD-2-Clause"
23LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
24 file://LICENSE;md5=866cc220f330b04ae4661fc3cdfedea7"
25DEPENDS = "ncurses"
26
27SRC_URI = "http://www.greenwoodsoftware.com/${BPN}/${BPN}-${PV}.tar.gz"
28
29SRC_URI[md5sum] = "7bc444bdb751bcf80ed0c39c17b4fcf4"
30SRC_URI[sha256sum] = "8305f5a06764ff094ed3428f94f29059541e2483eae201991f90823da6557212"
31
32inherit autotools update-alternatives
33
34do_install () {
35 oe_runmake 'bindir=${D}${bindir}' 'mandir=${D}${mandir}' install
36}
37
38ALTERNATIVE_${PN} = "less"
39ALTERNATIVE_PRIORITY = "100"