summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/iptables/iptables_1.6.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/iptables/iptables_1.6.2.bb')
-rw-r--r--meta/recipes-extended/iptables/iptables_1.6.2.bb49
1 files changed, 49 insertions, 0 deletions
diff --git a/meta/recipes-extended/iptables/iptables_1.6.2.bb b/meta/recipes-extended/iptables/iptables_1.6.2.bb
new file mode 100644
index 0000000000..628f5b7c4a
--- /dev/null
+++ b/meta/recipes-extended/iptables/iptables_1.6.2.bb
@@ -0,0 +1,49 @@
1SUMMARY = "Tools for managing kernel packet filtering capabilities"
2DESCRIPTION = "iptables is the userspace command line program used to configure and control network packet \
3filtering code in Linux."
4HOMEPAGE = "http://www.netfilter.org/"
5BUGTRACKER = "http://bugzilla.netfilter.org/"
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263\
8 file://iptables/iptables.c;beginline=13;endline=25;md5=c5cffd09974558cf27d0f763df2a12dc"
9
10RRECOMMENDS_${PN} = "kernel-module-x-tables \
11 kernel-module-ip-tables \
12 kernel-module-iptable-filter \
13 kernel-module-iptable-nat \
14 kernel-module-nf-defrag-ipv4 \
15 kernel-module-nf-conntrack \
16 kernel-module-nf-conntrack-ipv4 \
17 kernel-module-nf-nat \
18 kernel-module-ipt-masquerade"
19FILES_${PN} =+ "${libdir}/xtables/ ${datadir}/xtables"
20
21SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.bz2 \
22 file://types.h-add-defines-that-are-required-for-if_packet.patch \
23 file://0001-configure-Add-option-to-enable-disable-libnfnetlink.patch \
24 file://0002-configure.ac-only-check-conntrack-when-libnfnetlink-enabled.patch \
25 file://0001-fix-build-with-musl.patch \
26"
27
28SRC_URI[md5sum] = "7d2b7847e4aa8832a18437b8a4c1873d"
29SRC_URI[sha256sum] = "55d02dfa46263343a401f297d44190f2a3e5113c8933946f094ed40237053733"
30
31inherit autotools pkgconfig
32
33EXTRA_OECONF = "--with-kernel=${STAGING_INCDIR} \
34 "
35PACKAGECONFIG ?= "${@bb.utils.filter('DISTRO_FEATURES', 'ipv6', d)}"
36
37PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
38
39# libnfnetlink recipe is in meta-networking layer
40PACKAGECONFIG[libnfnetlink] = "--enable-libnfnetlink,--disable-libnfnetlink,libnfnetlink libnetfilter-conntrack"
41
42# libnftnl recipe is in meta-networking layer(previously known as libnftables)
43PACKAGECONFIG[libnftnl] = "--enable-nftables,--disable-nftables,libnftnl"
44
45do_configure_prepend() {
46 # Remove some libtool m4 files
47 # Keep ax_check_linker_flags.m4 which belongs to autoconf-archive.
48 rm -f libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4
49}