summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/iptables/iptables_1.4.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/iptables/iptables_1.4.8.bb')
-rw-r--r--meta/recipes-extended/iptables/iptables_1.4.8.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-extended/iptables/iptables_1.4.8.bb b/meta/recipes-extended/iptables/iptables_1.4.8.bb
new file mode 100644
index 0000000000..ad707d30bc
--- /dev/null
+++ b/meta/recipes-extended/iptables/iptables_1.4.8.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "iptables is the userspace command line program used to configure the Linux 2.4.x and 2.6.x IPv4 packet filtering ruleset"
2HOMEPAGE = "http://www.netfilter.org/"
3BUGTRACKER = "http://bugzilla.netfilter.org/"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b \
6 file://iptables.c;firstline=13;endline=25;md5=f1028f2401da1c120df27594b2be50ef"
7
8PR = "r0"
9
10RRECOMMENDS_${PN} = "kernel-module-x-tables \
11 kernel-module-ip-tables \
12 kernel-module-iptable-filter \
13 kernel-module-iptable-nat \
14 kernel-module-nf-defrag-ipv4 \
15 kernel-module-nf-conntrack \
16 kernel-module-nf-conntrack-ipv4 \
17 kernel-module-nf-nat \
18 kernel-module-ipt-masquerade"
19FILES_${PN}-dbg =+ "${libexecdir}/xtables/.debug"
20
21SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.bz2"
22
23inherit autotools
24
25EXTRA_OECONF = "--with-kernel=${STAGING_INCDIR} \
26 ${@base_contains('DISTRO_FEATURES', 'ipv6', '', '--disable-ipv6', d)}"
27
28do_configure_prepend() {
29 # they are all libtool m4 files
30 rm -rf ${S}/m4
31}