summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/iptables/iptables_1.4.21.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/iptables/iptables_1.4.21.bb')
-rw-r--r--meta/recipes-extended/iptables/iptables_1.4.21.bb46
1 files changed, 46 insertions, 0 deletions
diff --git a/meta/recipes-extended/iptables/iptables_1.4.21.bb b/meta/recipes-extended/iptables/iptables_1.4.21.bb
new file mode 100644
index 0000000000..dc17d575dd
--- /dev/null
+++ b/meta/recipes-extended/iptables/iptables_1.4.21.bb
@@ -0,0 +1,46 @@
1SUMMARY = "Tools for managing kernel packet filtering capabilities"
2DESCRIPTION = "iptables is the userspace command line program used to configure and control network packet \
3filtering code in Linux."
4HOMEPAGE = "http://www.netfilter.org/"
5BUGTRACKER = "http://bugzilla.netfilter.org/"
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263\
8 file://iptables/iptables.c;beginline=13;endline=25;md5=c5cffd09974558cf27d0f763df2a12dc"
9
10RRECOMMENDS_${PN} = "kernel-module-x-tables \
11 kernel-module-ip-tables \
12 kernel-module-iptable-filter \
13 kernel-module-iptable-nat \
14 kernel-module-nf-defrag-ipv4 \
15 kernel-module-nf-conntrack \
16 kernel-module-nf-conntrack-ipv4 \
17 kernel-module-nf-nat \
18 kernel-module-ipt-masquerade"
19FILES_${PN} =+ "${libdir}/xtables/ ${datadir}/xtables"
20FILES_${PN}-dbg =+ "${libdir}/xtables/.debug"
21
22SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.bz2 \
23 file://types.h-add-defines-that-are-required-for-if_packet.patch \
24 file://0001-configure-Add-option-to-enable-disable-libnfnetlink.patch \
25 "
26
27SRC_URI[md5sum] = "536d048c8e8eeebcd9757d0863ebb0c0"
28SRC_URI[sha256sum] = "52004c68021da9a599feed27f65defcfb22128f7da2c0531c0f75de0f479d3e0"
29
30inherit autotools pkgconfig
31
32EXTRA_OECONF = "--with-kernel=${STAGING_INCDIR} \
33 "
34PACKAGECONFIG ?= "${@bb.utils.contains('DISTRO_FEATURES', 'ipv6', 'ipv6', '', d)} \
35 "
36
37PACKAGECONFIG[ipv6] = "--enable-ipv6,--disable-ipv6,"
38
39# libnfnetlink recipe is in meta-networking layer
40PACKAGECONFIG[libnfnetlink] = "--enable-libnfnetlink,--disable-libnfnetlink,libnfnetlink"
41
42do_configure_prepend() {
43 # Remove some libtool m4 files
44 # Keep ax_check_linker_flags.m4 which belongs to autoconf-archive.
45 rm -f libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4
46}