summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/iptables/iptables_1.4.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/iptables/iptables_1.4.17.bb')
-rw-r--r--meta/recipes-extended/iptables/iptables_1.4.17.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-extended/iptables/iptables_1.4.17.bb b/meta/recipes-extended/iptables/iptables_1.4.17.bb
new file mode 100644
index 0000000000..f8ef7b6552
--- /dev/null
+++ b/meta/recipes-extended/iptables/iptables_1.4.17.bb
@@ -0,0 +1,40 @@
1SUMMARY = "Tools for managing kernel packet filtering capabilities"
2DESCRIPTION = "iptables is the userspace command line program used to configure and control network packet \
3filtering code in Linux."
4HOMEPAGE = "http://www.netfilter.org/"
5BUGTRACKER = "http://bugzilla.netfilter.org/"
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263\
8 file://iptables/iptables.c;beginline=13;endline=25;md5=c5cffd09974558cf27d0f763df2a12dc"
9
10PR = "r0"
11
12RRECOMMENDS_${PN} = "kernel-module-x-tables \
13 kernel-module-ip-tables \
14 kernel-module-iptable-filter \
15 kernel-module-iptable-nat \
16 kernel-module-nf-defrag-ipv4 \
17 kernel-module-nf-conntrack \
18 kernel-module-nf-conntrack-ipv4 \
19 kernel-module-nf-nat \
20 kernel-module-ipt-masquerade"
21FILES_${PN} =+ "${libdir}/xtables/ ${datadir}/xtables"
22FILES_${PN}-dbg =+ "${libdir}/xtables/.debug"
23
24SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.bz2 \
25 file://types.h-add-defines-that-are-required-for-if_packet.patch \
26 file://fix-link-failure-ip6t-NETMAP.patch \
27 file://fix-iptables-extensions-build-error.patch"
28SRC_URI[md5sum] = "c3fb2ffd5b39d0d54b06ccc4c8660116"
29SRC_URI[sha256sum] = "51e7a769469383b6ad308a6a19cdd2bd813cf4593e21a156a543a1cd70554925"
30
31inherit autotools
32
33EXTRA_OECONF = "--with-kernel=${STAGING_INCDIR} \
34 ${@base_contains('DISTRO_FEATURES', 'ipv6', '', '--disable-ipv6', d)}"
35
36do_configure_prepend() {
37 # Remove some libtool m4 files
38 # Keep ax_check_linker_flags.m4 which belongs to autoconf-archive.
39 rm -f libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4
40}