summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/iptables/iptables_1.4.12.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/iptables/iptables_1.4.12.2.bb')
-rw-r--r--meta/recipes-extended/iptables/iptables_1.4.12.2.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-extended/iptables/iptables_1.4.12.2.bb b/meta/recipes-extended/iptables/iptables_1.4.12.2.bb
new file mode 100644
index 0000000000..2d3d3113bb
--- /dev/null
+++ b/meta/recipes-extended/iptables/iptables_1.4.12.2.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Tools for managing kernel packaet filtering capabilities"
2DESCRIPTION = "iptables is the userspace command line program used to configure and control network packet \
3filtering code in Linux."
4HOMEPAGE = "http://www.netfilter.org/"
5BUGTRACKER = "http://bugzilla.netfilter.org/"
6LICENSE = "GPLv2+"
7LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263\
8 file://iptables/iptables.c;firstline=13;endline=25;md5=f1028f2401da1c120df27594b2be50ef"
9
10PR = "r0"
11
12RRECOMMENDS_${PN} = "kernel-module-x-tables \
13 kernel-module-ip-tables \
14 kernel-module-iptable-filter \
15 kernel-module-iptable-nat \
16 kernel-module-nf-defrag-ipv4 \
17 kernel-module-nf-conntrack \
18 kernel-module-nf-conntrack-ipv4 \
19 kernel-module-nf-nat \
20 kernel-module-ipt-masquerade"
21FILES_${PN} =+ "${libdir}/xtables/"
22FILES_${PN}-dbg =+ "${libdir}/xtables/.debug"
23
24SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.bz2 \
25 file://GNUmakefile.patch"
26
27SRC_URI[md5sum] = "212112389c7f10c72efb31a4ed193a4c"
28SRC_URI[sha256sum] = "09fff7dfe6af95675474fd5d0fc67622fac5a0f3d6e02ee614deae9a2e5dae13"
29
30inherit autotools
31
32EXTRA_OECONF = "--with-kernel=${STAGING_INCDIR} \
33 ${@base_contains('DISTRO_FEATURES', 'ipv6', '', '--disable-ipv6', d)}"
34
35do_configure_prepend() {
36 # Remove some libtool m4 files
37 # Keep ax_check_linker_flags.m4 which belongs to autoconf-archive.
38 rm -f libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4
39}