summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/images/core-image-testcontroller-initramfs.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/images/core-image-testcontroller-initramfs.bb')
-rw-r--r--meta/recipes-extended/images/core-image-testcontroller-initramfs.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-extended/images/core-image-testcontroller-initramfs.bb b/meta/recipes-extended/images/core-image-testcontroller-initramfs.bb
new file mode 100644
index 0000000000..2bc035a538
--- /dev/null
+++ b/meta/recipes-extended/images/core-image-testcontroller-initramfs.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "Small image capable of booting a device with custom install scripts, \
2adding a second rootfs, used for testing."
3
4# use -testfs live-install scripts
5PACKAGE_INSTALL = "initramfs-live-boot initramfs-live-install-testfs initramfs-live-install-efi-testfs busybox udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
6
7# Do not pollute the initrd image with rootfs features
8IMAGE_FEATURES = ""
9
10export IMAGE_BASENAME = "core-image-testcontroller-initramfs"
11IMAGE_NAME_SUFFIX ?= ""
12IMAGE_LINGUAS = ""
13
14LICENSE = "MIT"
15
16IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
17inherit core-image
18
19IMAGE_ROOTFS_SIZE = "8192"
20IMAGE_ROOTFS_EXTRA_SPACE = "0"
21BAD_RECOMMENDATIONS += "busybox-syslog"
22
23# Use the same restriction as initramfs-live-install-testfs
24COMPATIBLE_HOST = "(i.86|x86_64).*-linux"