summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/hdparm/hdparm_9.43.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/hdparm/hdparm_9.43.bb')
-rw-r--r--meta/recipes-extended/hdparm/hdparm_9.43.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-extended/hdparm/hdparm_9.43.bb b/meta/recipes-extended/hdparm/hdparm_9.43.bb
new file mode 100644
index 0000000000..805f76a6b3
--- /dev/null
+++ b/meta/recipes-extended/hdparm/hdparm_9.43.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Utility for viewing/manipulating IDE disk drive/driver parameters"
2DESCRIPTION = "hdparm is a Linux shell utility for viewing \
3and manipulating various IDE drive and driver parameters."
4SECTION = "console/utils"
5LICENSE = "BSD"
6LICENSE_wiper = "GPLv2"
7LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=910a8a42c962d238619c75fdb78bdb24 \
8 file://debian/copyright;md5=a82d7ba3ade9e8ec902749db98c592f3 \
9 file://wiper/GPLv2.txt;md5=fcb02dc552a041dee27e4b85c7396067 \
10 file://wiper/wiper.sh;beginline=7;endline=31;md5=b7bc642addc152ea307505bf1a296f09"
11
12
13PACKAGES =+ "wiper"
14
15FILES_wiper = "${bindir}/wiper.sh"
16
17RDEPENDS_wiper = "bash gawk stat"
18
19SRC_URI = "${SOURCEFORGE_MIRROR}/hdparm/hdparm-${PV}.tar.gz "
20
21SRC_URI[md5sum] = "f73233be118d86c779a8463d8b6a3cdb"
22SRC_URI[sha256sum] = "2bbe92274971182192901ab220e94bd2e4896f924fa6b225d0cffd7d8c16b52a"
23
24EXTRA_OEMAKE += 'STRIP="echo"'
25
26inherit update-alternatives
27
28ALTERNATIVE_${PN} = "hdparm"
29ALTERNATIVE_LINK_NAME[hdparm] = "${base_sbindir}/hdparm"
30ALTERNATIVE_PRIORITY = "100"
31
32do_install () {
33 install -d ${D}/${base_sbindir} ${D}/${mandir}/man8 ${D}/${bindir}
34 oe_runmake 'DESTDIR=${D}' 'sbindir=${base_sbindir}' install
35 cp ${S}/wiper/wiper.sh ${D}/${bindir}
36}