summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/hdparm/hdparm_9.39.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/hdparm/hdparm_9.39.bb')
-rw-r--r--meta/recipes-extended/hdparm/hdparm_9.39.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta/recipes-extended/hdparm/hdparm_9.39.bb b/meta/recipes-extended/hdparm/hdparm_9.39.bb
new file mode 100644
index 0000000000..d8342ccd4f
--- /dev/null
+++ b/meta/recipes-extended/hdparm/hdparm_9.39.bb
@@ -0,0 +1,36 @@
1DESCRIPTION = "hdparm is a Linux shell utility for viewing \
2and manipulating various IDE drive and driver parameters."
3SECTION = "console/utils"
4LICENSE = "BSD"
5LICENSE_wiper = "GPLv2"
6LIC_FILES_CHKSUM = "file://LICENSE.TXT;md5=910a8a42c962d238619c75fdb78bdb24 \
7 file://debian/copyright;md5=a82d7ba3ade9e8ec902749db98c592f3 \
8 file://wiper/GPLv2.txt;md5=fcb02dc552a041dee27e4b85c7396067 \
9 file://wiper/wiper.sh;beginline=7;endline=31;md5=b7bc642addc152ea307505bf1a296f09"
10
11PACKAGES += "wiper"
12
13FILES_wiper = "${bindir}/wiper.sh"
14FILES_${PN} = "${base_sbindir} ${mandir}"
15
16RDEPENDS_wiper = "bash gawk stat"
17
18SRC_URI = "${SOURCEFORGE_MIRROR}/hdparm/hdparm-${PV}.tar.gz "
19
20SRC_URI[md5sum] = "2bc17b72403885d4faf959682944243b"
21SRC_URI[sha256sum] = "72d550af4526aa96f0841c79321a0ee39d636cbaf1f294e52193e90c054b3cea"
22
23do_install () {
24 install -d ${D}/${base_sbindir} ${D}/${mandir}/man8 ${D}/${bindir}
25 oe_runmake 'DESTDIR=${D}' 'sbindir=${base_sbindir}' install
26 mv ${D}${base_sbindir}/hdparm ${D}${base_sbindir}/hdparm.${PN}
27 cp ${S}/wiper/wiper.sh ${D}/${bindir}
28}
29
30pkg_postinst_${PN} () {
31 update-alternatives --install ${base_sbindir}/hdparm hdparm hdparm.${PN} 100
32}
33
34pkg_prerm_${PN} () {
35 update-alternatives --remove hdparm hdparm.${PN}
36}