summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/gzip/gzip_1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/gzip/gzip_1.9.bb')
-rw-r--r--meta/recipes-extended/gzip/gzip_1.9.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta/recipes-extended/gzip/gzip_1.9.bb b/meta/recipes-extended/gzip/gzip_1.9.bb
new file mode 100644
index 0000000000..a8eeba1380
--- /dev/null
+++ b/meta/recipes-extended/gzip/gzip_1.9.bb
@@ -0,0 +1,38 @@
1require gzip.inc
2
3LICENSE = "GPLv3+"
4
5SRC_URI = "${GNU_MIRROR}/gzip/${BP}.tar.gz \
6 file://run-ptest"
7SRC_URI_append_class-target = " file://wrong-path-fix.patch"
8
9LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504 \
10 file://gzip.h;beginline=8;endline=20;md5=6e47caaa630e0c8bf9f1bc8d94a8ed0e"
11
12PROVIDES_append_class-native = " gzip-replacement-native"
13
14BBCLASSEXTEND = "native"
15
16inherit ptest
17
18do_install_ptest() {
19 mkdir -p ${D}${PTEST_PATH}/src/build-aux
20 cp ${S}/build-aux/test-driver ${D}${PTEST_PATH}/src/build-aux/
21 mkdir -p ${D}${PTEST_PATH}/src/tests
22 cp -r ${S}/tests/* ${D}${PTEST_PATH}/src/tests
23 sed -e 's/^abs_srcdir = ..*/abs_srcdir = \.\./' \
24 -e 's/^top_srcdir = ..*/top_srcdir = \.\./' \
25 -e 's/^GREP = ..*/GREP = grep/' \
26 -e 's/^AWK = ..*/AWK = awk/' \
27 -e 's/^srcdir = ..*/srcdir = \./' \
28 -e 's/^Makefile: ..*/Makefile: /' \
29 -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
30 -e 's|${DEBUG_PREFIX_MAP}||g' \
31 -e 's:${HOSTTOOLS_DIR}/::g' \
32 -e 's:${BASE_WORKDIR}/${MULTIMACH_TARGET_SYS}::g' \
33 ${B}/tests/Makefile > ${D}${PTEST_PATH}/src/tests/Makefile
34}
35
36SRC_URI[md5sum] = "929d6a6b832f75b28e3eeeafb30c1d9b"
37SRC_URI[sha256sum] = "5d2d3a3432ef32f24cdb060d278834507b481a75adeca18850c73592f778f6ad"
38