summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/gzip/gzip_1.3.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/gzip/gzip_1.3.12.bb')
-rw-r--r--meta/recipes-extended/gzip/gzip_1.3.12.bb27
1 files changed, 1 insertions, 26 deletions
diff --git a/meta/recipes-extended/gzip/gzip_1.3.12.bb b/meta/recipes-extended/gzip/gzip_1.3.12.bb
index 45a33ffdd1..e4062827bd 100644
--- a/meta/recipes-extended/gzip/gzip_1.3.12.bb
+++ b/meta/recipes-extended/gzip/gzip_1.3.12.bb
@@ -1,8 +1,4 @@
1SUMMARY = "Standard GNU compressor" 1require gzip.inc
2DESCRIPTION = "GNU Gzip is a popular data compression program originally written by Jean-loup Gailly for the GNU \
3project. Mark Adler wrote the decompression part"
4HOMEPAGE = "http://www.gnu.org/software/gzip"
5SECTION = "base"
6 2
7LICENSE = "GPLv2+" 3LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \ 4LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
@@ -17,24 +13,3 @@ SRC_URI[md5sum] = "b5bac2d21840ae077e0217bc5e4845b1"
17SRC_URI[sha256sum] = "3f565be05f7f3d1aff117c030eb7c738300510b7d098cedea796ca8e4cd587af" 13SRC_URI[sha256sum] = "3f565be05f7f3d1aff117c030eb7c738300510b7d098cedea796ca8e4cd587af"
18 14
19PR = "r2" 15PR = "r2"
20
21inherit autotools
22
23do_install_append () {
24 # move files into /bin (FHS)
25 install -d ${D}${base_bindir}
26 mv ${D}${bindir}/gunzip ${D}${base_bindir}/gunzip
27 mv ${D}${bindir}/gzip ${D}${base_bindir}/gzip
28 mv ${D}${bindir}/zcat ${D}${base_bindir}/zcat
29 mv ${D}${bindir}/uncompress ${D}${base_bindir}/uncompress
30}
31
32inherit update-alternatives
33
34ALTERNATIVE_${PN} = "gzip gunzip zcat"
35ALTERNATIVE_LINK_NAME[gzip] = "${base_bindir}/gzip"
36ALTERNATIVE_LINK_NAME[gunzip] = "${base_bindir}/gunzip"
37ALTERNATIVE_LINK_NAME[zcat] = "${base_bindir}/zcat"
38ALTERNATIVE_PRIORITY = "100"
39
40BBCLASSEXTEND = "native"