summaryrefslogtreecommitdiffstats
path: root/meta/recipes-extended/gzip/gzip_1.3.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-extended/gzip/gzip_1.3.12.bb')
-rw-r--r--meta/recipes-extended/gzip/gzip_1.3.12.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-extended/gzip/gzip_1.3.12.bb b/meta/recipes-extended/gzip/gzip_1.3.12.bb
new file mode 100644
index 0000000000..45a33ffdd1
--- /dev/null
+++ b/meta/recipes-extended/gzip/gzip_1.3.12.bb
@@ -0,0 +1,40 @@
1SUMMARY = "Standard GNU compressor"
2DESCRIPTION = "GNU Gzip is a popular data compression program originally written by Jean-loup Gailly for the GNU \
3project. Mark Adler wrote the decompression part"
4HOMEPAGE = "http://www.gnu.org/software/gzip"
5SECTION = "base"
6
7LICENSE = "GPLv2+"
8LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
9 file://gzip.h;endline=22;md5=c0934ad1900d927f86556153d4c76d23 \
10 file://lzw.h;endline=19;md5=c273e09a02edd9801cc74d39683049e9 "
11
12SRC_URI = "${GNU_MIRROR}/gzip/gzip-${PV}.tar.gz \
13 file://m4-extensions-fix.patch \
14 file://dup-def-fix.patch"
15
16SRC_URI[md5sum] = "b5bac2d21840ae077e0217bc5e4845b1"
17SRC_URI[sha256sum] = "3f565be05f7f3d1aff117c030eb7c738300510b7d098cedea796ca8e4cd587af"
18
19PR = "r2"
20
21inherit autotools
22
23do_install_append () {
24 # move files into /bin (FHS)
25 install -d ${D}${base_bindir}
26 mv ${D}${bindir}/gunzip ${D}${base_bindir}/gunzip
27 mv ${D}${bindir}/gzip ${D}${base_bindir}/gzip
28 mv ${D}${bindir}/zcat ${D}${base_bindir}/zcat
29 mv ${D}${bindir}/uncompress ${D}${base_bindir}/uncompress
30}
31
32inherit update-alternatives
33
34ALTERNATIVE_${PN} = "gzip gunzip zcat"
35ALTERNATIVE_LINK_NAME[gzip] = "${base_bindir}/gzip"
36ALTERNATIVE_LINK_NAME[gunzip] = "${base_bindir}/gunzip"
37ALTERNATIVE_LINK_NAME[zcat] = "${base_bindir}/zcat"
38ALTERNATIVE_PRIORITY = "100"
39
40BBCLASSEXTEND = "native"